Ask a Question

Error starting TestComplete on command line without CrossBrowsing Cloud Device installed

SOLVED
rrivest
Contributor

Error starting TestComplete on command line without CrossBrowsing Cloud Device installed

I'm using a simple .cmd file with parameters to launch TestComplete (intended for TestExecute): 

ECHO OFF
ECHO ENVIRONMENT = %1
ECHO PROJECT = %2
ECHO SCENARIO = %3
REM /SilentMode
"C:\Program Files (x86)\SmartBear\TestComplete 14\Bin\TestComplete.exe" "C:\Users\rrivest\Documents\PWC_Docs\PWC_Work\PLM_Automation\PWC_Auto.pjs" /r /p:%2 /u:CommandRunner /rt:CommandRunner /e /ns /el:C:\Temp\mylog.mht /ENV:%1 /TEST:%3

ECHO %ERRORLEVEL%

In the ProjectSuite and in every project, there's no reference to CrossBrowser nor is the Cloud Device extension installed or enabled.  However, the TestedApps are for 4 of the projects IExplore and one uses Chrome and they are defined in each projects, even the Common one which only holds common functions for all projects.

 

I always get this Error Dialog (hence the REM for /SilentMode for now)

 

CmdLineError.jpg

 

As well, when TestComplete opens, it is always trying to pack the projectsuite as if it had to send it somewhere... 

 

Any hints or suggestions ?

1 ACCEPTED SOLUTION

Accepted Solutions
TanyaYatskovska
Community Manager

Re: Error starting TestComplete on command line without CrossBrowsing Cloud Device installed

Hi @rrivest,

Do you have TestComplete Jenkins plugin installed? 

I'm asking as this plugin has the /env parameter and it can make TestComplete use the CBT integration (more information). Can you please remove /env from your batch file and check if you see the same error?

---------
Tanya Yatskovskaya
SmartBear Community and Education Manager


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

5 REPLIES 5
Marsha_R
Community Hero

Re: Error starting TestComplete on command line without CrossBrowsing Cloud Device installed

I suggest contacting Support directly.  Here's the link:

https://support.smartbear.com/message/?prod=TestComplete


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
rrivest
Contributor

Re: Error starting TestComplete on command line without CrossBrowsing Cloud Device installed

What I don't get is why I get this reference to CrossBrowser when none is required nor is the license included...

Marsha_R
Community Hero

Re: Error starting TestComplete on command line without CrossBrowsing Cloud Device installed

Ask Support that question while you are talking to them.


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
rrivest
Contributor

Re: Error starting TestComplete on command line without CrossBrowsing Cloud Device installed

I<m curious to see if anyone else had encountered that issue

TanyaYatskovska
Community Manager

Re: Error starting TestComplete on command line without CrossBrowsing Cloud Device installed

Hi @rrivest,

Do you have TestComplete Jenkins plugin installed? 

I'm asking as this plugin has the /env parameter and it can make TestComplete use the CBT integration (more information). Can you please remove /env from your batch file and check if you see the same error?

---------
Tanya Yatskovskaya
SmartBear Community and Education Manager


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
cancel
Showing results for 
Search instead for 
Did you mean: