Ask a Question

Enter at character (@) using Keys method

New Contributor

Enter at character (@) using Keys method



In my test script, I open the application MobaXterm then I need to enter a string that contains the at character (@).

I recorded these actions but when I played it again the @ is not entered.

In the support I found these two links:



But they didn't solved my problem.


Any other suggestion? Consider I use the Italian keyboard and normally to enter the at character I need to press the "Alt Gr" key plus "ò" key.





Thanks in advance, 



Community Hero

See if the native language section in here is helpful

[Community Hero]
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.


try use twice @@, (in []) mybe working.


if not working, please share your code!


In the following the code lines


let applications = Sys.Process("explorer").Window("Shell_TrayWnd").Window("ReBarWindow32").Window("MSTaskSwWClass", "Running applications");
applications.Window("MSTaskListWClass", "Running applications").Click();

let formXterm = Sys.Process("MobaXterm").VCLObject("FormXterm");
let panSessions = formXterm.VCLObject("PanGauche").VCLObject("sPanel13").VCLObject("PCGauche").VCLObject("sTabSessions").VCLObject("PanSessions");
panSessions.VCLObject("TreeSessions").DblClickItem("|User sessions| (admin)");


formXterm.VCLObject("sPanel1").Window("TListBox").Keys("ssh admin[@@][Enter]");



The problem is the last line. I tried the single @ and double @ (without [ ] ) but they don't work.


@Andrea_Bonacchi ,


This probably isn't very helpful, but we use Moba Personal Edition V12.4 Build 4248 and the following does work for us


FWIW, we recorded the keyword test and then converted it to a script. That probably doesn't matter but I thought I'd mention it.

Also, we have added Moba as a TestComplete TestedApp. 

Good Luck,




I use German keyboard, for me symbol @ = "ALT GR" + "Q".

Method "Keys" prints "@" for me without additional brackets and other characters.

Check whether you use different languages during testing (keyboard and system, as well as application language). Maybe that's the problem.

SmartBear Alumni (Retired)

Thanks Community! Great thread!


@Andrea_Bonacchi did the advice help? Please mark the best reply as a Solution here.

If you need additional assistance, please contact the Customer Case Team.

Sonya Mihaljova
Community and Education Specialist

Showing results for 
Search instead for 
Did you mean: