Ask a Question

Device Keys not working properly

Occasional Contributor

Device Keys not working properly

When adding a text or number field using device keys, then running the test it takes only a part of the inserted text or digit.

Please note that we tried to change the delay time between events in the project settings but nothing worked out.


Community Hero

Is it always the beginning of inserted data that is mising ? or could be also end of data ?

If it's always the beginning, perhaps the field need to be focused before text insertion is done ?


One base app like Message on your mobile, does the behaviour is the same ? (e.g. find if it's due to your tested app or your test technique ?).



Un sourire et ça repart

Occasional Contributor

Actually this is happening at the beginning or end of the inserted text with no rule  ..

I have tried to enable the android agent keyboard then choose the multilingual keyboard emulator and now it's working .

is similar experience with me, but now is working correctly

tangerang,best regards

Showing results for 
Search instead for 
Did you mean: