Ask a Question

Desktop trial license (fixed user) denies acces to TestComplete just 4 days into 30 day trial period

Occasional Contributor

Desktop trial license (fixed user) denies acces to TestComplete just 4 days into 30 day trial period

Any idea why does this happen?
I'm putting together a Proof of Concept for my manager and this is a showstopper and blocker, putting the consideration o this product at risk for us.

Champion Level 3

Occasional Contributor

All that I checked BEFORE installing it on an AWS hosted VM (and I also opened a case with support).
That's 4 days (using it nonstop and running just fine) into the 30 day trial period.

Champion Level 3

I understand that you are frustrated.  I am just one of the volunteers who answer questions on the forums and I gave you the best answers for the information you gave me.  You might be surprised at the number of users who don't read the directions before they start out.  It's good that you do.


Opening a support case is the best path for you so I'm glad you've already done that.  Once you get an answer from them, if you have time, please post the resolution here so we can all learn from it.


Have a good weekend.

Occasional Contributor

Hello there,

I would expect people who bother to try it out, to bother to read the requirements (it's not like the list is THAT long or complex).
In any case, support did provide a solution, and IT WORKED.

Here's the full response:
The error you received while trying to uninstall has been encountered in previous versions and was usually fixed by clearing the registries on the machine. Alternatively you can try running the installer with the command line parameter "-cleanup". This should properly remove any registries TestComplete had added during the installation, allowing you to perform the reinstallation.

If you still receive the error, then we may need to manually remove them. Please clear the TestComplete-related registries from these folders:
* Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\
* Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstal
* Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\SmartBear\TestComplete\14.0

I tried running the installer with that option exactly like this:
"TestComplete_T859671843957SLM.exe -SLM -silentmode -cleanup"

And that did the trick: I was able to reinstall TC (ran the installer again due to previous uninstall failed attempt) just fine.
And told them it may be a good idea to add this to the Q&A section.

Champion Level 3

You may expect that but you would be frequently disappointed!


Thank you for posting the solution.  



It's great to know that the problem was solved.


> Desktop trial license (fixed user) ...

> ... installing it on an AWS hosted VM

Node-locked (Fixed user) license is not recommended to be installed on the VMs due to possible problems with licensing subsystem - and


  /Alex [Community Champion]
[Community Champions] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Champions]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Champion] signature is assigned on quarterly basis and is used with permission by SmartBear Software.
Showing results for 
Search instead for 
Did you mean: