Ask a Question

'ClickCell' method has stopped working with error: "An error occurred"

Frequent Contributor

'ClickCell' method has stopped working with error: "An error occurred"



I need to select cells on a table widget of our desktop app. I have been able to successfully do this using the ClickCell method and this was working perfectly ok for a while (more than a year). However in last couple of weeks, this method has started failing with an error "An error occurred".


I also recorded a script by performing the steps manually. Then I ran this recorded script (attached below). This script also fails with the same error. I do not see the issue when I click the cells manually. The issue is only when running a script.


Recorded script:

function Test12()
var tableWidget;
tableWidget = Aliases.....tableWidgetProjects;
tableWidget.ClickCell("1", "Name");
tableWidget.ClickCell("2", "Name");


Under 'Additional Info':

Possible reasons:
1. The application stopped responding.
2. The application was compiled incorrectly (see the Open Applications topic in the help system).
3. An error occurred in TestComplete/TestExecute.

Technical information:
37 0x8002802b (Element not found.) .

Tested object:


Any help is appreciated. Thanks!


I would check first if your current object "table widget" in app matches what you have saved in TC as your Alias.

Then would do the same for one widget, using Object Spy.
It is possible that visually for user there was nothing has changed and all objects in view are same as before, but with other properties und structure.

Thank you for your reply!

I updated my TestComplete to the latest 14.9 ad the issue went away. Working good now.

Showing results for 
Search instead for 
Did you mean: