Ask a Question

Checkpoint wizard minimizes the recorded UWP application.

bodego55
New Contributor

Checkpoint wizard minimizes the recorded UWP application.

Hi, Forum: 

I am having an issue when adding checkpoints to my Keyboard tests. The application that I am recording is a UWP app.

(Universal Windows Platforms). Until two weeks ago, Testcomplete was allowing me to create checkpoints without any type of issues. The checkpoints were Object property, or Image property, and after I selected the element on the UWP app that I wanted, the screen that I was recording used to remain active, and it would allow me to continue recording the test, 

but now, as soon as I select the checkpoint option, and select it in the UWP screen, the UWP application gets minimized, 

and then when I am done with the checkpoint, in Testcomplete, I am left only with the Windows Desktop. Neither the TestComplete is visible (it is minimized in the taskbar) and the UWP as well is minimized. 

I have made sure that Minimize Testcomplete during recording is not flagged.

I ensured that Support for Windows Store applications is flagged.

I upgraded my TestComplete program to the latest version  14.50.976.7 x64 dated 7/20/2020

I made sure that tablet mode is off

Any help or additional information will be greatly appreciated.

Thanks

5 REPLIES 5
Marsha_R
Community Hero

Did you upgrade before or after this started happening?

Are you running on the same machine that you were before this started happening?

 

 


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame

Hi, Marsha_R:

Thanks for asking about my request.

I upgraded the version after the problem was present. This was done upon suggestion from SmartBear Technical support. 

The machine is the same. It is a dedicated machine. Its only purpose is to run TestComplete.

 

You should continue your case with Support.  They will have more information than we do.


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
bodego55
New Contributor

Hi, Marsha_R: I am trying to rely on Tech Support, but this issue is totally blocking me, and I am still waiting for another suggestion from Technical Support. 

It may be possible that somebody in this forum had experienced something similar, or have any suggestion that I may try since this has brought me to a total stop on my project.

 

 

sonya_m
SmartBear Alumni (Retired)

Hi @bodego55 , I see that our support engineer replied to you in case 00444298 yesterday. Please keep working with them. 

 

Let's see if the Community has more suggestions for you, too.

@AlexKaras @m_essaid @BenoitB @Reshail any ideas what's happening here?

 

According to the case, what's done so far:

 

- enabling the "Automatically display Mobile Screen on OnScreen operation" option didn't help

- restoring the default toolbar didn't help either


Sonya Mihaljova
Community and Education Specialist

cancel
Showing results for 
Search instead for 
Did you mean: