Ask a Question

Cannot connect to AzureDevOps project

simonaferrara
Contributor

Cannot connect to AzureDevOps project

Hi all,

 

I've got an issue on my Test Complete project, for the connection to the Azure DevOps project (to make it possible to link Test Cases to the Test Complete test items).

 

I've already configured and used it through a VM within my physical machine (test items are linked to test cases); this issue appears when I use a VM within another company machine, with the same test complete project.

 

A first error appears when I open the project on the machine:

simonaferrara_0-1638198339360.png

Note: if I open Azure DevOps from a web browser and I set my credentials, I can connect to the AzureDevOps without issues.

 

Then... if I try, from a test item (where in this machine I don't see the test case id), to click on the test case browser.. there is a message telling that it is connecting.. but after that the following error appears:

simonaferrara_1-1638198605308.png

 

Then... I've tried to unbind the project and then newly bind it, and also to create a new project and try to bind it to AzureDevOps.. but this error appears:

simonaferrara_2-1638198882204.png

 

Can you give me a suggestion on how I could check?

 

Thanks and regards

Simona

 

2 REPLIES 2

Hi Simona, thanks for reaching out!

Are the TestComplete versions the same on you local VM and the 2nd VM ? Is the Azure DevOps instance available in a web browser from the 2nd VM? 

Thanks,
Dermot

Hi @dermotcanniffe 

Yes, I've got the same Test Complete version on both machines (14.91.341.7).

Yes, I can connect to the Azure DevOps instance on the second machine, after set my credentials. When I try to bind the project, there is immediately this error (it doesn't allow to set my credentials, like it happens on the first machine; maybe could it be possible to specify somewhere the credentials to Azure DevOps?)

cancel
Showing results for 
Search instead for 
Did you mean: