cancel
Showing results for 
Search instead for 
Did you mean: 

TestComplete Using Chrome - Unable to find the object BrowserWindow(0)

SOLVED
Occasional Contributor

TestComplete Using Chrome - Unable to find the object BrowserWindow(0)

Running TestComplete using the Chrome browser, when Chrome is first started, a blank screen is shown for a variable amount of time ("White Screen of Death").  After adding steps to get around this, when I get to the page I want to work with, I keep getting the following error:

Unable to find the object BrowserWindow(0). See Additional Information for details.

The object "BrowserWindow(0)" does not exist.

Afterward, multiple step fail that have the BrowserWindow(0) object.  I am not sure how to get around this. 

I was able to collect an object snapshot.  Instead of BrowserWindow(0), I get something like the following:

Window("Chrome_WidgetWin_1", "WEBPAGE- Google Chrome", 2)

15 REPLIES
Community Hero

Re: TestComplete Using Chrome - Unable to find the object BrowserWindow(0)

It sounds like you don't have chrome properly configured, should be intereacting with pages, not the Window object. 

 

Have you gone through the steps here: https://support.smartbear.com/testcomplete/docs/app-testing/web/general/preparing-browsers/chrome.ht...


Thanks,
Carson

Click the Accept as Solution button if my answer has helped
Community Manager

Re: TestComplete Using Chrome - Unable to find the object BrowserWindow(0)

Hi @bb1832j,

 

Did @cunderw's suggestion help you? 

Also, it's worth checking if you have the TestComplete Web module activated.

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
Community Hero

Re: TestComplete Using Chrome - Unable to find the object BrowserWindow(0)

@bb1832j:
Hi,


-- Version of TestComplete?

-- Version of Chrome?

-- Is there a need for the TestComplete Chrome support update ? (https://support.smartbear.com/downloads/testcomplete/chrome-patches/)

-- Was TestComplete installed before or after Chrome?

 

Regards,
Alex
[Community Expert Group]
____
[Community Expert Group] members are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Postings made by [Community Expert Group] members
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
[Community Expert Group] signature is used with permission by SmartBear Software.
http://smartbear.com/forums/f83/t86934/community-experts/
================================
Occasional Contributor

Re: TestComplete Using Chrome - Unable to find the object BrowserWindow(0)

Hello @cunderw,

I looked over the steps that you suggested.  I am properly configured, I have been able to run on Chrome in the past.

I have some steps that use the BrowserWindow object because it contained actions that I required to use.

Occasional Contributor

Re: TestComplete Using Chrome - Unable to find the object BrowserWindow(0)

Hello @TanyaGorbunova,

I did try @cunderw steps.  Please see my post.

We do have the Web module installed and activated.

Occasional Contributor

Re: TestComplete Using Chrome - Unable to find the object BrowserWindow(0)

Hello @AlexKaras,

Here is the info you requested...

TestComplete Version: 12.60.5545.7

Chrome Version: 69.0.3497.100

TestComplete was reinstalled after Chrome update.

There have been no patches applied.

Community Hero

Re: TestComplete Using Chrome - Unable to find the object BrowserWindow(0)

Hi,

 

Hm-m... These versions should work...

Have you checked that Chrome extension is installed and enabled in Chrome? https://support.smartbear.com/testcomplete/docs/app-testing/web/general/preparing-browsers/chrome-ex...

 

Regards,
Alex
[Community Expert Group]
____
[Community Expert Group] members are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Postings made by [Community Expert Group] members
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
[Community Expert Group] signature is used with permission by SmartBear Software.
http://smartbear.com/forums/f83/t86934/community-experts/
================================
Occasional Contributor

Re: TestComplete Using Chrome - Unable to find the object BrowserWindow(0)

Hello @AlexKaras,

Yes, Chrome is installed and enabled. I am able to run a few steps before the problem occurs.

Community Hero

Re: TestComplete Using Chrome - Unable to find the object BrowserWindow(0)

Hi,

 

> [...] before the problem occurs.

Can you double check that extension is enabled in Chrome?

I am asking because as far as I remember, there are only two reasons of why Page object may be absent in the TestComplete Object Browser for Chrome and/or Firefox: either update is not installed for the new unsupported version of browser or extension got disabled in Chrome. (This might happen from time to time.)

 

Regards,
Alex
[Community Expert Group]
____
[Community Expert Group] members are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Postings made by [Community Expert Group] members
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
[Community Expert Group] signature is used with permission by SmartBear Software.
http://smartbear.com/forums/f83/t86934/community-experts/
================================
2018 NEWS
Top Kudoed Authors