cancel
Showing results for 
Search instead for 
Did you mean: 

Test Execute keyword test fails due to mapping issues, same keyword test is passing in Test Complete

Frequent Contributor

Test Execute keyword test fails due to mapping issues, same keyword test is passing in Test Complete

 
17 REPLIES 17
Highlighted
Community Hero

Re: Test Execute keyword test fails due to mapping issues, same keyword test is passing in Test Comp

Well, okay, you have a test that fails in TE but not in TC.   If you need help with that, we're going to need a lot more information.  

 

Start with this:

What is the test?

How do you know it failed?

What did you try to resolve it?

What versions of TE and TC are you running?

Are the two tests running on the same computer?

Are the two tests running on the same version of the application that you are testing?

 

 

Frequent Contributor

Re: Test Execute keyword test fails due to mapping issues, same keyword test is passing in Test Comp

 

What is the test? Ens to end scenario keyword test which has aLogin test within it.

How do you know it failed? Log is displaying the failure.

What did you try to resolve it? remapped one element in Project Test of test complete and it worked in Test Execute

What versions of TE and TC are you running? 14 versions in both TE and TC. TE Version: 14.10.1042.11 x64

TC Version: 14.10.1042.7 x64

Are the two tests running on the same computer? Yes on the same VM

Are the two tests running on the same version of the application that you are testing? Yes 

Community Hero

Re: Test Execute keyword test fails due to mapping issues, same keyword test is passing in Test Comp

Does the remapped object work in both TC and TE? 

Does the rest of the test run in both places now that you've changed it?

Frequent Contributor

Re: Test Execute keyword test fails due to mapping issues, same keyword test is passing in Test Comp

I am just remapping in Project test in Test Complete , but my regular scripts have different mappings.

Community Hero

Re: Test Execute keyword test fails due to mapping issues, same keyword test is passing in Test Comp

Is it broken in more than one place?  You said one and now you're mentioning more.  We really need more details if you want help.  Show us your test, show us the mapping that used to work and what you had to change it to.  Explain it as if you were showing us this at your desk.

Frequent Contributor

Re: Test Execute keyword test fails due to mapping issues, same keyword test is passing in Test Comp

Every element needs to be remapped in my Project Test that I am using in Test Execute.

When I use Test Complete to run my scripts which are not in the Test Project the scripts are working

Community Hero

Re: Test Execute keyword test fails due to mapping issues, same keyword test is passing in Test Comp

Giving us all this information at once would really be better.  See how long it is taking to maybe get an answer?

 

Now it looks like you are saying that the TC tests are different from the TE tests.  Is that true?

 

 

Frequent Contributor

Re: Test Execute keyword test fails due to mapping issues, same keyword test is passing in Test Comp

I highlighted the main project that is MAsterProject_ECS360 in Test complete and the login script that I highlighted under that is origibal script. It has been working for 9 months in Test Complete .

I created a TestProject1 to run through Test Execute and copied the Login_Ecs360_Chantilly script from MasterProject_Ecs360 .

Both Login scripts are the same but the script Login_Ecs360_Chantilly under TestProject1 when I ran it through Tets Execute or manually in Test complete it was failing and made me remap the objects again and after remapping only it worked through Test Execute and manually in Tets Complete.

What is the difference between teh two projects? nothing

My issue is if I add other scripts that are multiple objects will I need to remap them again if I need to run through Test Execute.

 

Hope I am able to explain the issue in screenshot below.

Project.png

Community Hero

Re: Test Execute keyword test fails due to mapping issues, same keyword test is passing in Test Comp

Thanks for the details, those are helpful.

 

If you use TE to run the login script in MasterProject instead of from TestProject, does it work?

New Here?
Join us and watch the welcome video:
SeptemberNews
Join the September Hub-bub to show off, learn and win