cancel
Showing results for 
Search instead for 
Did you mean: 

Object Browser showing two identical objects with same index

Contributor

Object Browser showing two identical objects with same index

Hi,



I'm running TestComplete 7.52 on Windows 7 x64 and encountered an issue where two identical objects had the same exact index value on the same hierarchy level.  Usually, when there are identical objects, the index value is unique and can be used for NameMapping purposes.  However, it seems it is not reliable.



Here are two snapshots.  After restarting the AUT, the index property somehow corrected itself.  Please advise.
4 REPLIES 4
Moderator

RE: Object Browser showing two identical objects with same index

Hi,




If the problem appears again, please create a snapshot of your application's process. To learn how to create a snapshot, please see the "Save Object Snapshot Dialog" help topic. While saving the snapshot, check the "All properties" and "Save recursively" options in the Save Object Snapshot dialog. Submit a request via our Contact Support form (http://www.automatedqa.com/support/message/) and attach the resulting file to your request.

--
Dmitry Nikolaev
Customer Care Manager
TestComplete, QAComplete

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.
New Contributor

RE: Object Browser showing two identical objects with same index

I believe I am having a similar problem on my application.  Has there been a resolution to this and can you forward it to me or contact me about it?

RE: Object Browser showing two identical objects with same index

Hi Deborah,


It seems we have already replied to your request (Issue# M0069845) that you submitted via our Contact Support form. Let's continue working on the issue within this support case.


Best regards,
Alexey

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.
New Contributor

RE: Object Browser showing two identical objects with same index

I did get an answer from my inquiry thru support and thought I'd share it in the event others are still struggling with similar issues.  As with Kim's post, Index was an unreliable property to use as a unique identifier for the object property.  Each time I remapped the object's mapped name to include the index, when I reran the test there seem to be a different Index being used which made this reference unreliable. 



Since changing the native name of these objects was not an option for us, we needed to find another property which would remain constant.  We used an objectID.editvalue.olevalue with a boolean * for the variable parts. 



The other challenge we were having was that once we had two objects open which shared the same native name the second object would 'steal' the name mapping from the first.  The key we discovered was that we had to assign the identifying property(ies) to the original mapped object first before opening its twin.  This way the twin opens without mapping and you can then, in the object browser, right click the now unmapped object, and select 'map the object name'.  Otherwise Test Complete will indicate object is already mapped and will not allow you to map it with unique properties. 
New Here?
Join us and watch the welcome video:
Top Kudoed Authors