cancel
Showing results for 
Search instead for 
Did you mean: 

Login Problem: HTTP/1.1 408 The time allowed for the login ... exceeded.

Highlighted
New Contributor

Login Problem: HTTP/1.1 408 The time allowed for the login ... exceeded.

Hi,



I have to write Task with Login into web-page and doing something there.



I wrote very simplest Tasks fist - just open web-page, login, and logout - with one Virtual User only!

After several attempts I have only one successful Task (I mean run Scripts results)

Unfortunately, I can't repeat to record this simple Task again, because HTTP 408 Error (see below Response)



"Project Log -> Requests -> Headers" contains next Request and Response info:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

POST /page1/j_security_check HTTP/1.1

Accept: image/gif, image/jpeg, image/pjpeg, image/pjpeg, application/x-shockwave-flash, application/x-silverlight, application/x-ms-application, application/x-ms-xbap, application/vnd.ms-xpsdocument, application/xaml+xml, application/vnd.ms-excel, application/msword, */*

Referer: http://192.168.1.128:8080/page1/index.do

Accept-Language: en-us

User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)

Content-Type: application/x-www-form-urlencoded

Accept-Encoding: gzip, deflate

Host: 192.168.1.128:8080

Content-Length: 44

Connection: Keep-Alive

Cache-Control: no-cache

HTTP/1.1 408 The time allowed for the login process has been exceeded. If you wish to continue you must either click back twice and re-click the link you requested or close and re-open your browser

Server: Apache-Coyote/1.1

Content-Type: text/html;charset=utf-8

Content-Length: 1554

Date: Wed, 09 Dec 2009 20:27:09 GMT

Connection: close

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~



I have enough Send/Receive time-out values in the "Tools->Options->Engines->HTTP Load Testing->Traffic Transponder" settings - I set 36000 s both.

Manually, Login process takes short time: 1-2 seconds without any errors



Actually I need more complex Task - not login-logout only, but doing something there after login.

But I can't.



There is cause of HTTP 408 error?



TestComplete 6.40.344.7

Windows XP 2002 SP3



Thanks,

Alex


4 REPLIES 4
Highlighted
New Contributor

RE: Login Problem: HTTP/1.1 408 The time allowed for the login ... exceeded.

Additional question concern to subject.


Actually, even single successful simplest Task has three Warnings in the Project Log.

All three have almost the same Request’s Headers in the Project Log, like this:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

GET /page1/loudoun/index.do HTTP/1.1

Accept: image/gif, image/jpeg, image/pjpeg, image/pjpeg, application/x-shockwave-flash, application/x-silverlight, application/x-ms-application, application/x-ms-xbap, application/vnd.ms-xpsdocument, application/xaml+xml, application/vnd.ms-excel, application/msword, */*

Referer: http://192.168.1.128:8080/page1/custom.do?mode=top&tab=

Accept-Language: en-us

User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)

Accept-Encoding: gzip, deflate

Host: 192.168.1.128:8080

Connection: Keep-Alive


HTTP/1.1 302 Moved Temporarily

Server: Apache-Coyote/1.1

Pragma: No-cache

Cache-Control: no-cache

Expires: Thu, 01 Jan 1970 00:00:00 GMT

Set-Cookie: JSESSIONID=D447CBCCD929B917D3CCF3C55BC9A5EA; Path=/

Location: http://192.168.1.128:8080/page1/index.do;jsessionid=D447CBCCD929B917D3CCF3C55BC9A5EA

Content-Type: text/html

Content-Length: 0

Date: Thu, 10 Dec 2009 16:26:40 GMT

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Differences exist in GET requests and JSESSIONID values.


JSESSIONID values are different, because I set parameter [Cookie handling] = “Use real-time cookies” in the “Tools->Options->Engines->HTTP Load Testing->Traffic Transponder”.


All three Requests with Warnings contain the same Respond: “HTTP/1.1 302 Moved Temporarily”.


That this Respond means?

Maybe it connected with above described problem?


Highlighted
New Contributor

RE: Login Problem: HTTP/1.1 408 The time allowed for the login ... exceeded.

Additional question concern to subject.


Actually, even single successful simplest Task has three Warnings in the Project Log.

All three have almost the same Request’s Headers in the Project Log, like this:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

GET /page1/loudoun/index.do HTTP/1.1

Accept: image/gif, image/jpeg, image/pjpeg, image/pjpeg, application/x-shockwave-flash, application/x-silverlight, application/x-ms-application, application/x-ms-xbap, application/vnd.ms-xpsdocument, application/xaml+xml, application/vnd.ms-excel, application/msword, */*

Referer: http://192.168.1.128:8080/page1/custom.do?mode=top&tab=

Accept-Language: en-us

User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)

Accept-Encoding: gzip, deflate

Host: 192.168.1.128:8080

Connection: Keep-Alive


HTTP/1.1 302 Moved Temporarily

Server: Apache-Coyote/1.1

Pragma: No-cache

Cache-Control: no-cache

Expires: Thu, 01 Jan 1970 00:00:00 GMT

Set-Cookie: JSESSIONID=D447CBCCD929B917D3CCF3C55BC9A5EA; Path=/

Location: http://192.168.1.128:8080/page1/index.do;jsessionid=D447CBCCD929B917D3CCF3C55BC9A5EA

Content-Type: text/html

Content-Length: 0

Date: Thu, 10 Dec 2009 16:26:40 GMT

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Differences exist in GET requests and JSESSIONID values.


JSESSIONID values are different, because I set parameter [Cookie handling] = “Use real-time cookies” in the “Tools->Options->Engines->HTTP Load Testing->Traffic Transponder”.


All three Requests with Warnings contain the same Respond: “HTTP/1.1 302 Moved Temporarily”.


That this Respond means?



Maybe it connected with above described problem?

Because single successful Task has the same Respond: “HTTP/1.1 302 Moved Temporarily


Highlighted
New Contributor

RE: Login Problem: HTTP/1.1 408 The time allowed for the login ... exceeded.

I'm apologies for duplicate message, but I just tried slightly correct last one - I add last sentence.

I think it will be very useful to allow users correct new post during several minutes after post creating.
Highlighted

RE: Login Problem: HTTP/1.1 408 The time allowed for the login ... exceeded.

Hi Alex,


First of all, I recommend that you see the following thread for information on warnings in load testing:

http://www.automatedqa.com/forums/d.cgi?cmd=xover&group=automatedqa.public.testcomplete&related=3299...=


Note that only the response code is verified (cookies and the response body are not verified).


For information on errors in load testing, please see the following SQAforums thread:

http://www.sqaforums.com/showflat.php?Cat=0&Number=593794&an=0&page=0&gonew=1#UNREAD


Note that the errors occur when a connection was closed unexpectedly. This can be caused by two facts:

1. The connection was terminated from TestComplete due to Load Testing timeout settings (see the "Traffic Transponder" section of the "HTTP Load Testing Options" help topic for more information).

2. The connection was forcibly closed by the tested web server (in this case, the "Connection: close" string will be present in the header of the web server's response which comes last in the problematic connection).


To find the cause of the problems, it is necessary to know how the web server works and to analyze the actual traffic sent to the web server to find the difference between the expected and actual requests and responses. Note that in some cases, requests may be correct, and the problem can actually be caused by the web server and/or the web application itself. If the information provided above is not enough for you to find the cause of the problem, please zip your entire project suite folder along with the log of the failed test execution and send us the archive via our Contact Support form (http://www.automatedqa.com/support/message). Make sure that messages in your log correspond to the latest version of your tests.


>>>

I think it will be very useful to allow users correct new post during several minutes after post creating.

<<<

We are planning to add the functionality soon.



Best regards,
Alexey

 Join SmartBear Connect next April in Boston to meet with software development, API and testing experts from around the world! Get your ticket today!