cancel
Showing results for 
Search instead for 
Did you mean: 

SoapUI 4/5 difference - Getting Error getting response;NULL

SOLVED
Highlighted
New Contributor

SoapUI 4/5 difference - Getting Error getting response;NULL

Hi
I'm experiencing major difference between soapUI 4 and 5 version behavior.
In my project I have a WS-Security configured, Outgoing with Signature and Encryption, also Incoming WS-Security.

While using SoapUI 4 I receive proper response from my server.
Unfortunately, while using SoapUI 5 I get:
Error getting response for [my_request]; null. Nothing appears in Response box.


I'm checking my server and i can see in it's log files that the request was successfully received and processed.
It's only a problem with response for SoapUI...

The configuration is the same for both SoapUI's, I think i checked everywhere for any differences.
Same problem in SoapUI 5 Pro version.

Has anyone encounter same problem ? What could be the solution ?


Thanks in advance for any clue what to do.

Best regards
Pawel
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
New Contributor

Re: SoapUI 4/5 difference - Getting Error getting response;N

[Solved] I was getting the message "error getting response; null".

I added the files "wss4j-1.6.18.jar" and "xmlsec-1.5.8.jar" as shown below in SoapUI 5.4.0. so i solved my problem about that message. You can get the lib files "wss4j-1.6.18.jar" and "xmlsec-1.5.8.jar" from ReadyAPI 2.6.0 that you downloaded .

Untitled.png

 

View solution in original post

8 REPLIES 8
Highlighted
Occasional Contributor

Re: SoapUI 4/5 difference - Getting Error getting response;N

Hi

I am experiencing the same behavior in my setup.
However, when I turn off the Incoming WS-Security configuration, the encrypted message is received just fine.
As such, my guess is that the problem lies within the Incoming WS-Security process, maybe during the decryption.

A solution would be very much appreciated

Best regards
Christian
Highlighted
New Contributor

Re: SoapUI 4/5 difference - Getting Error getting response;N

Hi Christian

Thanks for the information! Same situation here, when i turned off the Incomming wss for my request i've received the encrypted response.
Indeed, it looks like some issue occurs during the decryption phase.

SoapUI team, could you investigate the problem and prepare a fix ?

Best regards
Pawel
Highlighted
Occasional Contributor

Re: SoapUI 4/5 difference - Getting Error getting response;N

SoapUI team - is there any update on this issue?

Best regards
Christian
Highlighted
New Contributor

Re: SoapUI 4/5 difference - Getting Error getting response;N

On our side this problem occured as well (Error getting response for [...]; null). We could resolve it by exchanging the existing xmlsec-1.4.5.jar file contained in the /lib folder with newer version xmlsec-1.5.2.jar.

 

Highlighted
Visitor

Re: SoapUI 4/5 difference - Getting Error getting response;N

I tried that and it didn't work. However along same lines I looked at differences in the lib folder between old version which worked (4.5.0) and new version which didn't (5.1.3) and found a similar fix which did work for me:

 

C:\Program Files\SmartBear\SoapUI-5.1.3\lib

 

Rename wss4j-1.6.16.jar to wss4j-1.6.16.jar.old

Copy wss4j-1.6.2.jar from same location for SoapUI 4.5 to this folder.

 

Restart and it works now.

 

Thanks,

Barry

 

Highlighted
New Member

Re: SoapUI 4/5 difference - Getting Error getting response;N

I am experiencing the same issue.  When I turn off incoming WSS, I get a response in the response window, but it is encrypted.  With the incoming WSS setup, I get "error gtting response; null" and the response does not show in the window. 

 

I am receiving a response with the incoming WSS setup - I can save the response to a file using the Request Properties dump location and view it.  It just doesn't show in the response window.  And it is still encrypted, which is useless. 

 

I have tried wss4j-1.6.2.jar, wws4j-1.6.7.jar, and wws4j-1.6.14.jar.  No luck with any of them.

I have also tried replacing xmlsec-1.4.5.jar with xmlsec-1.5.2.jar.  Same issue still showing.

 

I am using SoapUI-Pro 5.1.2.  

 

Any other suggestions? 

 

Thank you!

 

Highlighted
New Contributor

Re: SoapUI 4/5 difference - Getting Error getting response;N

[Solved] I was getting the message "error getting response; null".

I added the files "wss4j-1.6.18.jar" and "xmlsec-1.5.8.jar" as shown below in SoapUI 5.4.0. so i solved my problem about that message. You can get the lib files "wss4j-1.6.18.jar" and "xmlsec-1.5.8.jar" from ReadyAPI 2.6.0 that you downloaded .

Untitled.png

 

View solution in original post

Highlighted
Community Manager

Re: SoapUI 4/5 difference - Getting Error getting response;N

Thanks for sharing your solution with us! I'll mark it accordingly.

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
New Here?
Join us and watch the welcome video:
Announcements
Script Wanted
Let's start July with new challenges!

Create a script to change request body before sending it to the server for the TechCorner tag!


Scripts created in June:
- A script to generate a request body based on data from Datasource
- A script to go through all response nodes and check the value of the required field
- A Dispatching script to get responses based on the values in Request Body
- A script to add a new tag and assign it to all TestCases in a TestSuite
Top Kudoed Authors