cancel
Showing results for 
Search instead for 
Did you mean: 

testrunner.sh -m option

Occasional Contributor

testrunner.sh -m option

Hi, I'm running soapUI 4.5.1 and was running some test projects from the command line using testrunner and ran into an issue. Not sure if this is a bug or user error and I don't see this question anywhere else in the forums, so I thought I'd ask about it.

Basically, this is what I'm running on my linux machine:
user@linuxbox:soapui_tests$ /apps/soapui_4.5.1/bin/testrunner.sh -m 0 MyWs_TestProject.xml

And what I get from that is the testrunner usage list (I won't waste space pasting it here, I'm sure you know what it looks like) and the message "Missing soapUI project file.."

If I try it without the -m option, it works fine. I've tried various combinations as well, -m0, which gives me an "Unrecognized option" error, and -m 1, which also just prints out the usage. I've tried just -m by itself, not really expecting it to work, and indeed, it fails with a "NumberFormatException".

It's not really critical or anything. I just don't use the exported failures because they make much more sense within the context of the full log, so I just delete them. Thought it would be nice if I could tell testrunner to omit them to begin with.

Thanks!
2 REPLIES 2
Community Hero

Re: testrunner.sh -m option

Check the link if not already
http://www.soapui.org/Test-Automation/f ... tests.html


Regards,
Rao.
Occasional Contributor

Re: testrunner.sh -m option

Rao,

Thanks, I had seen that page before, but I guess I didn't study the lower part closely enough to realize that it shows how testrunner is invoked with the options selected in the GUI. Unfortunately, I don't see in that dialog anything related to the maximum number of failures to export (the -m option). It's likely that I'm just selectively blind, though. Is there such an option in this dialog?

Thanks again!
New Here?
Join us and watch the welcome video:
Announcements