cancel
Showing results for 
Search instead for 
Did you mean: 

Soapui 5.6.0 ssl handshake exception

Gouravjoshi89
Occasional Contributor

Soapui 5.6.0 ssl handshake exception

Hi team,

I'm facing issue with soapui application with version 5.6.0

While running ouath I'm getting error as ssl handshake exception and unable to find the certificate in the folder.

Please try to resolve this ASAP
As I have seen many people posted this exception but no one replied yet
As this is common exception where everyone facing using soapui 5.6.0

Please provide immediate resolution

Thanks in advance
12 REPLIES 12
ZDGN
Contributor

Re: Soapui 5.6.0 ssl handshake exception

Hi @Gouravjoshi89 

 

May be you could find a solution there:

- Update or modify the server configuration

https://community.smartbear.com/t5/SoapUI-Open-Source/Solved-SSL-Handshake-exception-calling-a-secur...

- Modify the SoapUI runner configuration:
https://community.smartbear.com/t5/SoapUI-Open-Source/Getting-handshake-error-while-execution-of-pro...

 

In both case, something is wrong with the certification.

Let us know if this helps.

 

David.

Gouravjoshi89
Occasional Contributor

Re: Soapui 5.6.0 ssl handshake exception

Hi David,

 

Thanks for your below email.

 

As i could see URL which provided by you its shows "page not found "

Please share the valid URL

 

My issue is when i run my xml file it shows "soapui unable to find valid certification path with SSL handshake exception"

 

I need  the solution to resolve this issue

 

Regards

Gourav Joshi

Gouravjoshi89
Occasional Contributor

Re: Soapui 5.6.0 ssl handshake exception

Hi David,

 

I have attached the exception screenshot. Please find the same.

Im using soapui vrsion 5.6.0 and getting the attached error.

As i'm facing this issue from 1 month and still there is work around found for this issue.

 

please try to provide solution to fix it asap

ZDGN
Contributor
Gouravjoshi89
Occasional Contributor

Re: Soapui 5.6.0 ssl handshake exception

Hi David,

 

Below solution didnt work for me.

Im attaching my soapui.bat file [please modify and share me the updated file] and i have added the below testrunner file but it didnt work for me.

set java_opts=%java_opts% -dsoapui.https.protocols=TLSv1,TLSv1.2,SSLv3

set JAVA_OPTS=%JAVA_OPTS% -Dsoapui.browser.disabled="true"

Im attaching my bat file, please do the necessary changes and share me the update file or let me know where correction need to be done in bat file, so i will change accordingly.

 

My Soapui bat file contains below

+++++++++++++++++++++++++

@Echo off

set SOAPUI_HOME=%~dp0

set JAVA_HOME=I:\jdk-11.0.7

set JAVA=%JAVA_HOME%\bin\java

if not "%JAVA_HOME%" == "" goto SET_CLASSPATH

set JAVA=java

echo JAVA_HOME is not set, unexpected results may occur.
echo Set JAVA_HOME to the directory of your local JDK to avoid this message.

:SET_CLASSPATH

rem init classpath
set OLDDIR=%CD%
cd /d %SOAPUI_HOME%

set CLASSPATH=%SOAPUI_HOME%soapui-5.6.0.jar;%SOAPUI_HOME%..\lib\*
"%JAVA%" -cp "%CLASSPATH%" com.eviware.soapui.tools.JfxrtLocator > %TEMP%\jfxrtpath
set /P JFXRTPATH= < %TEMP%\jfxrtpath
del %TEMP%\jfxrtpath
set CLASSPATH=%CLASSPATH%;%JFXRTPATH%

rem JVM parameters, modify as appropriate

set JAVA_OPTS=-Xms128m -Xmx1024m -XX:MinHeapFreeRatio=20 -XX:MaxHeapFreeRatio=40 -Dsoapui.properties=soapui.properties "-Dsoapui.home=%SOAPUI_HOME%\" -splash:SoapUI-Spashscreen.png

if "%SOAPUI_HOME%" == "" goto START
set JAVA_OPTS=%JAVA_OPTS% -Dsoapui.ext.libraries="%SOAPUI_HOME%ext"
set JAVA_OPTS=%JAVA_OPTS% -Dsoapui.ext.listeners="%SOAPUI_HOME%listeners"
set JAVA_OPTS=%JAVA_OPTS% -Dsoapui.ext.actions="%SOAPUI_HOME%actions"
set JAVA_OPTS=%JAVA_OPTS% -Djava.library.path="%SOAPUI_HOME%\"
set JAVA_OPTS=%JAVA_OPTS% -Dwsi.dir="%SOAPUI_HOME%..\wsi-test-tools"
rem uncomment to disable browser component
rem set JAVA_OPTS=%JAVA_OPTS% -Dsoapui.browser.disabled="true"
:START

rem ********* run soapui ***********

"%JAVA%" %JAVA_OPTS% -cp "%CLASSPATH%" com.eviware.soapui.SoapUI %*
cd /d %OLDDIR%



Gouravjoshi89
Occasional Contributor

Re: Soapui 5.6.0 ssl handshake exception

Hi David,

 

Could you please help me where i need to ad below line in my soap ui file

guide me with proper steps where to add below line above/after where i need to add ?

 

set JAVA_OPTS=%JAVA_OPTS% -Dsoapui.https.protocols="SSLv3,TLSv1.2"

 -Dsoapui.https.protocols=SSLv3,TLSv1.2 

 

Thanks in advance

 

ZDGN
Contributor

Re: Soapui 5.6.0 ssl handshake exception

After saving your soapui.bat file, could you try this one ?

 

@Echo off
set SOAPUI_HOME=%~dp0
set JAVA_HOME=I:\jdk-11.0.7
set JAVA=%JAVA_HOME%\bin\java
if not "%JAVA_HOME%" == "" goto SET_CLASSPATH
set JAVA=java
echo JAVA_HOME is not set, unexpected results may occur.
echo Set JAVA_HOME to the directory of your local JDK to avoid this message.
:SET_CLASSPATH
rem init classpath
set OLDDIR=%CD%
cd /d %SOAPUI_HOME%
set CLASSPATH=%SOAPUI_HOME%soapui-5.6.0.jar;%SOAPUI_HOME%..\lib\*
"%JAVA%" -cp "%CLASSPATH%" com.eviware.soapui.tools.JfxrtLocator > %TEMP%\jfxrtpath
set /P JFXRTPATH= < %TEMP%\jfxrtpath
del %TEMP%\jfxrtpath
set CLASSPATH=%CLASSPATH%;%JFXRTPATH%
rem JVM parameters, modify as appropriate
set JAVA_OPTS=-Xms128m -Xmx1024m -XX:MinHeapFreeRatio=20 -XX:MaxHeapFreeRatio=40 -Dsoapui.properties=soapui.properties "-Dsoapui.home=%SOAPUI_HOME%\" -splash:SoapUI-Spashscreen.png
if "%SOAPUI_HOME%" == "" goto START
set JAVA_OPTS=%JAVA_OPTS% -Dsoapui.ext.libraries="%SOAPUI_HOME%ext"
set JAVA_OPTS=%JAVA_OPTS% -Dsoapui.ext.listeners="%SOAPUI_HOME%listeners"
set JAVA_OPTS=%JAVA_OPTS% -Dsoapui.ext.actions="%SOAPUI_HOME%actions"
set JAVA_OPTS=%JAVA_OPTS% -Djava.library.path="%SOAPUI_HOME%\"
set JAVA_OPTS=%JAVA_OPTS% -Dwsi.dir="%SOAPUI_HOME%..\wsi-test-tools"
rem uncomment to disable browser component
rem set JAVA_OPTS=%JAVA_OPTS% -Dsoapui.browser.disabled="true"
set JAVA_OPTS=%JAVA_OPTS% -Dsoapui.https.protocols="SSLv3,TLSv1.2"
:START
rem ********* run soapui ***********
"%JAVA%" %JAVA_OPTS% -cp "%CLASSPATH%" com.eviware.soapui.SoapUI %*
cd /d %OLDDIR%
Gouravjoshi89
Occasional Contributor

Re: Soapui 5.6.0 ssl handshake exception

HI,

 

After adding your below bat file im getting below message.

Hi there!

You're getting this message since your computer is offline and SoapUI can't access the Internet. Without an Internet connection, you might experience some issues when performing Web Service testing.

Usually, this is where you would see the SoapUI start page, which includes the latest news and other relevant information.

Make sure to connect to the Internet to get access to all the services and information from SmartBear.

Thanks!
The SmartBear SoapUI Team

Gouravjoshi89
Occasional Contributor

Re: Soapui 5.6.0 ssl handshake exception

HI David,

 

Still im getting save error.

 

what is the best possible to way to resolve thiss below exception, is this issue with certificate ?

  • 2021-05-04 23:05:26 - Error getting response; javax.net.ssl.SSLHandshakeException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
New Here?
Join us and watch the welcome video:
Top Kudoed Authors