cancel
Showing results for 
Search instead for 
Did you mean: 

SoapUI 5.1.2 Error using Maven plugin dependencies could not be resolved: jasperreports transfer

SOLVED
Shouse
New Contributor

SoapUI 5.1.2 Error using Maven plugin dependencies could not be resolved: jasperreports transfer

As of 5pm EST on Friday 4/16/2021 all of our longtime working MS Azure DevOps pipelines suddenly stopped working due to this error

 

[ERROR] Failed to execute goal com.smartbear.soapui:soapui-pro-maven-plugin:5.1.2:test (default) on project com.nms.smoke: Execution default of goal com.smartbear.soapui:soapui-pro-maven-plugin:5.1.2:test failed: Plugin com.smartbear.soapui:soapui-pro-maven-plugin:5.1.2 or one of its dependencies could not be resolved: Failed to collect dependencies at com.smartbear.soapui:soapui-pro-maven-plugin:jar:5.1.2 -> com.smartbear.soapui:soapui-pro:jar:5.1.2 -> jasperreports:jasperreports:jar:4.0.2: Failed to read artifact descriptor for jasperreports:jasperreports:jar:4.0.2: Could not transfer artifact jasperreports:jasperreports:pom:4.0.2 from/to maven2-repository.java.net (http://java.net/projects/maven-repository/😞 Transfer failed for http://java.net/projects/maven-repository/jasperreports/jasperreports/4.0.2/jasperreports-4.0.2.pom: Certificate for <java.net> doesn't match any of the subject alternative names: [*.java.net] -> [Help 1]

 

Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions
lazer1
New Contributor

Re: SoapUI 5.1.2 Error using Maven plugin dependencies could not be resolved: jasperreports transfer

In your pom.xml, use "soapui-maven-plugin", instead of "soapui-pro-maven-plugin".

View solution in original post

5 REPLIES 5
lazer1
New Contributor

Re: SoapUI 5.1.2 Error using Maven plugin dependencies could not be resolved: jasperreports transfer

Got the same error recently, like you. 
I think the standard open source version "soapui-maven-plugin" does not have this jasperReports dependency. I am currently trying this as a solution to bypass this issue. My project do not need pro features to run, so hopefully it will work. 
Will report back.

lazer1
New Contributor

Re: SoapUI 5.1.2 Error using Maven plugin dependencies could not be resolved: jasperreports transfer

My suggested workaround works. Confirmed this morning.

Shouse
New Contributor

Re: SoapUI 5.1.2 Error using Maven plugin dependencies could not be resolved: jasperreports transfer

Can you please add specific Maven plugin changes you made, urls needed, any other helpful info to this thread so others may try your solution

Sent from Mail for Windows 10
lazer1
New Contributor

Re: SoapUI 5.1.2 Error using Maven plugin dependencies could not be resolved: jasperreports transfer

In your pom.xml, use "soapui-maven-plugin", instead of "soapui-pro-maven-plugin".

View solution in original post

lazer1
New Contributor

Re: SoapUI 5.1.2 Error using Maven plugin dependencies could not be resolved: jasperreports transfer

-

New Here?
Join us and watch the welcome video:
Top Kudoed Authors