cancel
Showing results for 
Search instead for 
Did you mean: 

SOAPUI 5.5(MAC) Fails for EWS -- 401 Unauthorized

Highlighted
New Contributor

SOAPUI 5.5(MAC) Fails for EWS -- 401 Unauthorized

Hello Folks,

 

I am have a weird issue setting up SOAPUI connectivity to EWS. I have tried in past setting up the initial project with the provided WSDL and dont recall any issue however, I am trying to replicate that recently for the same webservices account and am getting "Receiving response: HTTP/1.1 401 Unauthorized"

 

Note: The only difference is earlier i tested when I was on windows desktop and now its a Mac.

Also note the previous imported projected from windows works fine on MAC including all its methods.

 

This is real bottleneck for me and is holding up my entire work backlog. Any assistance is greatly appreciated.

 

Thanks you

Raj

 

 

The WSDL used is internal like https://<servername>/Services.wsdl

 

Note: The URL requires authentication and works fine when accessesd via a Browser.

 

Things I have tried:

When I ADD WSDL to the project it runs logs like below and then Prompt for NT authenticationbut with No success. On that NT authentication pop up I have tried:

  • Provide domain\username, with its passowrd, and domain empty
  • Provide usermame , password and domain in their respective places

Change Preferences to use 1.0 for HTTP

Add credentials under "Outgoing WS-Seurity Configurations:

 

The failure mesage on UI :

Error loading [https://<servername>/ews/Services.wsdl]: org.apache.xmlbeans.XmlException: org.apache.xmlbeans.XmlException: error: Unexpected end of file after null

 

Logs are attached