cancel
Showing results for 
Search instead for 
Did you mean: 

Getting the following error ,while opening SoapUI 5.6

SOLVED
Arivazhagan-6
Frequent Visitor

Getting the following error ,while opening SoapUI 5.6

java.lang.UnsupportedClassVersionError: com/eviware/soapui/SoapUI has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:467)
at java.net.URLClassLoader.access$100(URLClassLoader.java:73)
at java.net.URLClassLoader$1.run(URLClassLoader.java:368)
at java.net.URLClassLoader$1.run(URLClassLoader.java:362)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:361)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:349)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at com.exe4j.runtime.LauncherEngine.launch(LauncherEngine.java:81)
at com.install4j.runtime.launcher.UnixLauncher.main(UnixLauncher.java:62)

 

1 ACCEPTED SOLUTION

Accepted Solutions
Islem
New Contributor

Re: Getting the following error ,while opening SoapUI 5.6

After a lot of Internet browsing and reading, I fixed the problem by installing Java SE 14 found on the page https://www.oracle.com/java/technologies/javase-downloads.html after clicking the link JDK Download.

 

It then tooks me to the page https://www.oracle.com/java/technologies/javase-jdk14-downloads.html where I downloaded the version I needed. Windows 10 for me so I picked up the jdk-14.0.2_windows-x64_bin.exe

 

And now, I can finally launch my Soap UI 5.6.0 successfully.

Thanks ✌️ 👌

View solution in original post

6 REPLIES 6
sippel
Occasional Visitor

Re: Getting the following error ,while opening SoapUI 5.6

Hi folks. Same problem occurs for me ... and it is not only for com/eviware/soapui/SoapUI, but for tools such as com/eviware/soapui/tools/JfxrtLocator, as well. System is Windows 10 with already installed jdk1.8 SopaUI 5.6 has been installed from SoapUI-5.6.0-windows-bin.zip. May it be that SoapUI 5.6 has a problem with Java 8 and does not run on jdk1.8 anymore? Best reagrds.
nmrao
Community Hero

Re: Getting the following error ,while opening SoapUI 5.6

Which version of java are you using?


Regards,
Rao.
Islem
New Contributor

Re: Getting the following error ,while opening SoapUI 5.6

Hello,

I have just made the BIG mistake of accepting to install the upgrade on Soap UI.
My previous version was Soap UI 5.5.0 and I had Java 8.181 installed and everything was fine...

Then, I still don't understand why, when I lauched my Soap UI, I've accepted to take the update...
Then I got the exaclty same error message (printed herewith by the way) after the installation.
Despite that Java is not anymore around version 52 or 53, but more like 7 or 8, I have understood that I needed to update also my Java Runtime.
What I have done by installing the latest Java version --> 8.261
Then, I still got the same error message...
After, I was thinking that I may be need to restart my PC, what I've done full of hope (I must even say, last hope)...
And guess what ?
Still the same error message when I lauch Soap UI !

That is why I'm here, can you please help me ?
It is really urgent I must say.

Islem
New Contributor

Re: Getting the following error ,while opening SoapUI 5.6

After a lot of Internet browsing and reading, I fixed the problem by installing Java SE 14 found on the page https://www.oracle.com/java/technologies/javase-downloads.html after clicking the link JDK Download.

 

It then tooks me to the page https://www.oracle.com/java/technologies/javase-jdk14-downloads.html where I downloaded the version I needed. Windows 10 for me so I picked up the jdk-14.0.2_windows-x64_bin.exe

 

And now, I can finally launch my Soap UI 5.6.0 successfully.

Thanks ✌️ 👌

View solution in original post

vipivoxa
New Member

Re: Getting the following error ,while opening SoapUI 5.6

It's weird, (in windows) there is a C:\Program Files\SmartBear\SoapUI-5.6.0\bin\soapui.bat which uses JAVA_HOME or SOAPUI_HOME env variable, in theory it should be enough to introduce a SOAPUI_HOME env variable e.g.: C:\Program Files\SmartBear\SoapUI-5.6.0

and because of jre is already included into installation it will be picked up.

Running than with soapui.bat seems fine when SOAPUI_HOME is set. 

 

But not with soapui.exe, this guy seems to be using system default jre.

 

 

 

 

 

sumitgts
New Member

Re: Getting the following error ,while opening SoapUI 5.6

JRE included as part of SoapUI 5.6 is with openjdk version 12.0.1 2019-04-16.

However, I have openjdk version 11.0.9 2020-10-20 as my default and still SoapUI 5.6 is giving error while opening up

java.lang.UnsupportedClassVersionError: com/eviware/soapui/SoapUI has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0

Any inputs on how to make SoapUI 5.6 work with OpenJDK11

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors