Ask a Question

hermes-config fail when running SoapUI using Jenkins

New Contributor

hermes-config fail when running SoapUI using Jenkins



I have installed SoapUI in a linux machine. Until now I have run the projects using the linux shell and they work fine.


To make it easier I have installed Jenkins in the linux machine, so, using a ssh tunnel I can launch my projects from my windows PC. I have launched several projects from my PC and they work properly in the linux machine. However, there is an problem, I need to be logged in the Linux machine, otherwise if I laucnh the project always get the same error:

15:24:33,662 ERROR [SoapUI] An error occurred [Session name 'SIAAM' does not exist in Hermes configuration or path to Hermes config ( /apps/users/USMSCIP/.hermes )is not valid!], see error log for details
javax.naming.NamingException: Session name 'SIAAM' does not exist in Hermes configuration or path to Hermes config ( /apps/users/USMSCIP/.hermes )is not valid!

It seems that everything works fine but somehow SoapUI can not read the hermes config file if I'm not logged in the machine. 

¿Does anybody know what the issue could be? The path to the hermes-config is correct, also the file. When I'm not logged, the tunnel and the jenkins instance keeps working. The problem is 'just' the hermes-config.

Community Hero

Hey @jmaduquel 


I dont know if this is going to help at all - but in regards to being logged on/not being logged on - if I remember correctly (and its been several years since I setup Jenkins/SoapUI) - doesnt Jenkins need to run on the same useraccount that SoapUI is logged on as?  Or am I totally misunderstanding?


That's all I've got I'm afraid....





if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

Yeah, you are right. However, that's not the problem. Jenkins is installed in the user folder so it works even if I´m not logged in the linux server (I can run all the projects except the ones that use hermes-config).


Anyway thanks for your answer.

Showing results for 
Search instead for 
Did you mean: