Ask a Question

WS-Security decrypt of incoming message failing with no error indication - SoapUI 5.2.1 on Ubuntu

downtown
Occasional Contributor

WS-Security decrypt of incoming message failing with no error indication - SoapUI 5.2.1 on Ubuntu

I receive a SOAP response message that is encrypted with the certificate that is stored in the Java keystore defined to SoapUI.

 

SoapUI keystore definitionSoapUI keystore definition

The SoapUI incoming WSS definition is:Incoming WSS configurationIncoming WSS configuration

 The request from SoapUI specifies the "Decrypt" incoming WSS.

The output from the web service is encrypted with the SoapUI/keystore's certificate.

The entry in the SoapUI/keystore:

keysfromclient, Mar 8, 2017, keyEntry,
Certificate fingerprint (SHA1): 0F:98:5D:50:F5:4B:97:C0:83:36:73:0E:66:03:AC:A2:9A:AE:68:92

When I send the request, I get the encrypted message in the "raw" tab of the response pane, and no error message in the error log.Response in "raw" tabResponse in "raw" tab

 Below the Request pane, there is a message "Error getting response: null"

The SoapUI log has:

Thu Mar 16 18:47:07 EDT 2017:DEBUG:Attempt 1 to execute request

Thu Mar 16 18:47:07 EDT 2017:DEBUG:Sending request: POST /BookingService/sign HTTP/1.1

Thu Mar 16 18:47:07 EDT 2017:DEBUG:Receiving response: HTTP/1.1 200 OK

Thu Mar 16 18:47:07 EDT 2017:DEBUG:Connection can be kept alive indefinitely

Thu Mar 16 18:47:07 EDT 2017:INFO:Error getting response for [BookingServiceSOAP.BookTravel:10- Crypto Request]; null

Thu Mar 16 18:47:40 EDT 2017:DEBUG:Connection closed



 The HTTP log has basically what is shown in the "raw" response pane.

The error log is empty.

 

Any ideas? I have no error messages to give me any guidance.

 

Jim

 

 

 

 

 

 

 

3 REPLIES 3
rupert_anderson
Valued Contributor

Re: WS-Security decrypt of incoming message failing with no error indication - SoapUI 5.2.1 on Ubunt

Hi,

 

I have noticed issues with null responses when using WSSecurity and decrypting the response (signatures seemed to work ok) - from memory, replacing jar 'xmlsec-1.4.5.jar' with 'xmlsec-1.5.6.jar' in the SoapUI lib folder might help?

 

Regards,

Rupert

Author of SoapUI Cookbook
downtown
Occasional Contributor

Re: WS-Security decrypt of incoming message failing with no error indication - SoapUI 5.2.1 on Ubunt

Bummer, I tried that with high hopes, but alas, still no joy.

In fact, SoapUI failed to add a signature for the outgoing message (a new problem).

I also saw a discussion that referenced wss4j-1.6.19.jar as a problem. I separately tried multiple levels of wss4j.jar, but no improvements.

One possible factor is that I am using the IBM JRE, rather than the bundled JRE (Oracle version?). Licensing issues with the non-IBM JREs...

Thanks for the reply tho,

 

Jim

amaciuca
New Member

Re: WS-Security decrypt of incoming message failing with no error indication - SoapUI 5.2.1 on Ubunt

Many thanks. This solved my pain on Ubuntu 16.04 and SoapUI 5.3. Almost a month of trying all kind of things.

One other (important!!!) thing to know about SoapUI: the key password MUST be the same as the keystore password.

cancel
Showing results for 
Search instead for 
Did you mean: