Ask a Question

could not import a definition from the specified file?


could not import a definition from the specified file?

Hi Team,

I am trying to import a wsdl but getting an error "could not import a definition from the specified file". I have tried None, Manual and Automatic in proxy settings but unsuccessful. I am able to import the wsdl in SOAPUI and on browser but not with ServiceV Pro ReadyAPI,  Let me know how can we import the wsdl. 



Senthil kumar. M

Community Hero

Hi @senthkum 


That's not actually much to go on to try and diagnose the problem and advise on a fix.


It would appear with just a quick glance at the error that's manifesting there is a problem with the contents of your .wsdl - but without more info I doubt anyone's gonna be able to help.


Typically if you can't load in a file it's because it's malformed but the fact you're loading it into a browser proves its wellformed xml.


As I say above -its likely to be the contents of the .wsdl that are causing the problem - if you can publish the .wsdl people will be able to look at it for you - but other than that - I can't help.


If you can't publish the file then the only other thing I can suggest is if you're XML is decent I'd recommend commenting out sections and trying to reload - but I wouldn't recommend this unless your XML is fairly good - you need to be cognizant of what you are commenting out and the implications to the file and how it gets parsed by the XMLparser.


Hope this helps a little,






if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
SmartBear Alumni (Retired)

Hi all,


Thank you for your comments, @richie.


@senthkum, did any of the above thoughts give you any ideas on how this could be solved? What stage are you on now?

Olga Terentieva
SmartBear Assistant Community Manager

Hi Richie,


Thanks for your response, I would like to share the wsdl link "" for your reference.  I was able to import the wsdl in SOAPUI and Parasoft, Please find the attachment for your rerefence.  When it can be imported in SOAUI, why is it failing in ServiceV pro ?. I can check with the developer in parallel on the issue. Let me know if I have missed anything.



Senthil kumar  

SmartBear Alumni (Retired)

Hi @senthkum,


This question requires some investigation. Could you please contact our Support Team for this?

Tanya Yatskovskaya
SmartBear Community and Education Manager

Showing results for 
Search instead for 
Did you mean: