Ask a Question

? changes to % in URL

New Contributor

? changes to % in URL

Hi Team,


I am sending endpoint using properties. In that wherever the '?' is there in endpoint it get changed to % sign.


I can't send the original endpoint.

Please consider below example as reference.

Endpoint required to send :- "send?like"  is like this

In request it sends :- "sending%like"   {Change is in bold}

Any assistance you can provide would be greatly appreciated.

Thank you

Community Hero

Hey @ab1402,

Im struggling to understand completely, could you clarify?

Is this SOAP or REST?

Youre saying a ? digit is being replaced by a % symbol on the that correct?

Is this in the URI or is this in the payload? Examples or both would help visualise your issue (and wont reveal anything from a security perspective)

Whats the MediaType setting in your request? (i.e. what is the Content-Type header value in your request? assuming you have one)

What version of ReadyAPI are you using?


if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
New Contributor

Thank you @richie

Issue which I have is similar to

However I not have any Idea to disable ASCII encoding in URL.
Would like to know is there any command or option to skip ASCII  encoding.

Thank you

Showing results for 
Search instead for 
Did you mean: