Ask a Question

Unable to use 4.5 due to keystore issues

Occasional Contributor

Unable to use 4.5 due to keystore issues

I am unable to upgrade to 4.5 due to problems adding or using existing keystores. I am currently using version 4.0 with keystores and incoming/outgoing configurations setup. This works without any problem. When I install 4.5 and import the same project, there is an I/O error in the keystore "status" field. Since I've tried removing and adding them back numerous times using multiple keystores, I know the password is correct. I have also verified I am able to import through Windows MMC and keytool.


Occasional Contributor

Any update to this issue? I noticed someone reported a bug, (SoapUI Pro 4.5 is not able to open p12 keystore), that appears to be the same issue.

As a workaround, a .jks keystore was created. I was able to load this in SoapUI and the keystore status displayed "OK". I was still not able to send messages though. I get an SSL peer authentication error. Outgoing security is configured the same as it is for version 4.0, which works.

Please advise as this prevents us from doing any testing in version 4.5.
Occasional Contributor

Is there another way to get support on an issue? For some reason, this post is not even being acknowledged.
SmartBear Alumni (Retired)


Can you send us error log?


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
Showing results for 
Search instead for 
Did you mean: