Ask a Question

UI and online documentation for JDBC requests not the same for versio 2.8.0. Is there a bug?

SOLVED
tsmith0422
New Contributor

UI and online documentation for JDBC requests not the same for versio 2.8.0. Is there a bug?

I am finding that when I select for a JDBC request the Stored Procedure box that I do not get the results that the documentation is saying that I should get.  Am I missing something or is there a bug?

 

When I click the Stored Procedure box the build query button goes away and nothing else is available (I have no Create Query dialog that opens). I have no query even started at the time I click the button so I do not have any output parameters. 

 

but the documenation says this:

Create a query with a stored procedure

To specify a call to a stored procedure in a query, do the following:

  1. Enable the Stored Procedure option.

  2. Click Create Query. It opens the Create Query dialog.

  3. Select the desired procedure and click OK.

 If the stored procedure includes output parameters, the Create Query dialog will not appear. To call a procedure that includes output parameters, do one of the following:

  • Disable the Stored Procedure option and write an SQL query manually using the SQL syntax.

—OR—

  • Create a Groovy Script test step and perform the needed operation via a script.

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
richie
Community Hero

Re: UI and online documentation for JDBC requests not the same for versio 2.8.0. Is there a bug?

Hi @tsmith0422

I'm a little confused. The screenshot you attached is SoapUI, not ReadyAPI!, but your post title mention v2.8.0?
You mention when you select the checkbox the 'create query' dialog doesn't open, but you have an editable field that is enabled that you can input the query into. As soon as you input text into that field, it enables the execute query button.

As youve used a soapui screenshot, are you using soapui or readyapi!

Make sure you're using the readyapi! Instructions rather than soapui instructions as they do differ in certain situations. It is possible the instructions may be a little out of date...theyre quite good but i do find occasionally they could do with an update.

Ok. Right. I just tried it out. There looks like there might be an intermittent defect. Im running v2.8.0 and the build quey button wasnt present on the form. I should highlight the build query always appeared greyed even though if present it is enabled. If you want to force the build query to generate and it doesnt appear on the form, if you change the connected db, then chnge it back to the correct connection, youll get a dialogue prompting if you want to build the query. Select ok and this will generate the build query form. As i sid above....theres a lot of minor defects in readyapi!, most often you can find a work around to get around the issue.

Smartbear probably already know about this one, but you can raise a ticket with support to ensure they are aware of it. Im sorry, im typing this out on my phone so cant provide the direct support link.

Cheers

Rich
if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

View solution in original post

sonya_m
Community Manager

Re: UI and online documentation for JDBC requests not the same for versio 2.8.0. Is there a bug?

Thank you for the investigation richie! 

 

Thanks for pointing this out @tsmith0422! Now, when Stored Procedure is selected, the Create Query button becomes invisible indeed. This moment hasn’t been documented properly but the Doc Team is going to fix it. 


Sonya Mihaljova
Community and Education Specialist

View solution in original post

2 REPLIES 2
richie
Community Hero

Re: UI and online documentation for JDBC requests not the same for versio 2.8.0. Is there a bug?

Hi @tsmith0422

I'm a little confused. The screenshot you attached is SoapUI, not ReadyAPI!, but your post title mention v2.8.0?
You mention when you select the checkbox the 'create query' dialog doesn't open, but you have an editable field that is enabled that you can input the query into. As soon as you input text into that field, it enables the execute query button.

As youve used a soapui screenshot, are you using soapui or readyapi!

Make sure you're using the readyapi! Instructions rather than soapui instructions as they do differ in certain situations. It is possible the instructions may be a little out of date...theyre quite good but i do find occasionally they could do with an update.

Ok. Right. I just tried it out. There looks like there might be an intermittent defect. Im running v2.8.0 and the build quey button wasnt present on the form. I should highlight the build query always appeared greyed even though if present it is enabled. If you want to force the build query to generate and it doesnt appear on the form, if you change the connected db, then chnge it back to the correct connection, youll get a dialogue prompting if you want to build the query. Select ok and this will generate the build query form. As i sid above....theres a lot of minor defects in readyapi!, most often you can find a work around to get around the issue.

Smartbear probably already know about this one, but you can raise a ticket with support to ensure they are aware of it. Im sorry, im typing this out on my phone so cant provide the direct support link.

Cheers

Rich
if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

View solution in original post

sonya_m
Community Manager

Re: UI and online documentation for JDBC requests not the same for versio 2.8.0. Is there a bug?

Thank you for the investigation richie! 

 

Thanks for pointing this out @tsmith0422! Now, when Stored Procedure is selected, the Create Query button becomes invisible indeed. This moment hasn’t been documented properly but the Doc Team is going to fix it. 


Sonya Mihaljova
Community and Education Specialist

View solution in original post

cancel
Showing results for 
Search instead for 
Did you mean: