Ask a Question

Selenium with ReadyApi 2.7.0


Selenium with ReadyApi 2.7.0



We have a project that uses selenium. It works in ReadyApi 2.6.0.


To get this working, we had to

- replace file guava-20.0.jar with guava-23.0.jar in Applications⁩ ▸ ⁨⁩ ▸ ⁨Contents⁩ ▸ ⁨java⁩ ▸ ⁨app⁩ ▸ ⁨lib⁩ (Mac version)

- put chromedriver.exe in ⁨Applications⁩ ▸ ⁨⁩ ▸ ⁨Contents⁩ ▸ ⁨java⁩ ▸ ⁨app⁩ ▸ ⁨bin⁩ ▸ ⁨ext⁩

Version used is 

- same with selenium-server-standalone-3.14.0.jar


I am trying the ReadyApi upgrade to 2.7.0. I see it has version guava-24.0.jar in its lib directory. If I run our project with chromedriver and selenium jar file copied to /bin/ext map, it does not work.

If I look at following page

it seems it shows outdated information.


Can someone please tell me which versions of which files I need to import to get Selenium working with ReadyApi 2.7.0? It took me some painstaking work to find this out for 2.6.0, and I am affraid it will be no difference for version 2.7.0. I tried some other chromedriver and selenium-server jar versions, to no avail.

Super Contributor

I don't have licensed verison of Ready API. But you can do trial and error method to verify which version would be suitable. I'd suggest you to use the latest one for chromedriver.exe, http-client.jar and selenium-standalone-server. Please follow below link solution which works in windows for free version of soapui-5.4.0


Still, if you are not able to find out. Please raise a support ticket providing your license id :-



Thank you for your answer.


Using trial and error is what I want to avoid. Its hard to find out which file is the culprit, as logging gives few insightful suggestions, especially to find out which version combinations of library files should be used.


I raised a support ticket, to your suggestion.

SmartBear Alumni (Retired)

Hi all,


@avidCoder, thank you for your reply.

@AlbertSoapUI, I hope our Customer Care team helps you solve this!
It would be very useful if you could share the results of their investigation here.

Thank you in advance!


Have a great day,

Olga Terentieva
SmartBear Assistant Community Manager

Customer care had found it out.

Turns out I had confused a file named jersey-guava-24.0.jar, which I had incorrectly replaced, with guava-20.0.jar, which had to be replaced with a newer version.

Documentation on is still correct.

It works now.

SmartBear Alumni (Retired)

Hi @AlbertSoapUI,

It is great to hear the issue is solved for you now! And thank you so much for sharing your results.

Have a good day!


Olga Terentieva
SmartBear Assistant Community Manager

Showing results for 
Search instead for 
Did you mean: