Forum Discussion

UnitTesters's avatar
5 years ago

Ready API 2.7.0 Not Launching

When I am launching Ready API the program wont launch

Logs give first warning 2019-07-26 10:39:58,591 WARN  [SoapUIExtensionClassLoader] The custom library "C:\Program Files\SmartBear\ReadyAPI-2.7.0\bin" does not exist.

Full logs attached

Can anyone help please?



  • Hi Olga_T 


    With support from customer care the issue was resolved this moring there was an issue with my soapui-settings.xml file.




7 Replies

    • Nastya_Khovrina's avatar
      SmartBear Alumni (Retired)

      Hi UnitTesters,


      Please check whether you have any invalid files in the <ReadyAPI_Install>\bin\ext directory. Try removing extra file from this folder and starting ReadyAPI again. By default, this folder includes only the following files: 

      postgresql-9.3-1102.jdbc41.jar, sqljdbc42.jar and readme.txt.


      Also, you can try deleting the workspace file (you won't loose your projects, you just will need to add them to the workspace again). The default soapui-workspace.xml file is in <user profile directory> i.e. C:\Users\yourusername on Windows.


      If this doesn't help, please open a new case here:


      • UnitTesters's avatar

        Hi Nastya_Khovrina 


        Thank you for the feedback and apologises for my delayed response.


        Unfortuanltey suggested solution below did not work my folder <ReadyAPI_Install>\bin\ext directory only contains the files reffered to below and I also tried removing projects from my workspace but still no lunk I will proceed with logging a new case


        Thank you again