Ask a Question

ReadyAPI 2.4 doesn't start

Occasional Contributor

ReadyAPI 2.4 doesn't start

I was about to update my version from 2.2 to 2.4, but my team member has upgraded from 2.3 to 2.4 and is just getting a blank screen.

Is there an issue with 2.4?

Community Hero

Can you provide more info? What operating system did your friend use? What do you mean by blank screen? Does it open a empty window? Does it not open it at all? Does he try to open ReadyApi by using a shortcut? Does he try to open it using the executable file?


If my answer helped please click on the 'Accept as Solution' button.
Occasional Contributor

Actually I have now found that the application froze when he tried to load a composite project previously created.  

He opened using a shortcut for 2.4 although he also tried from 2.3 after applying the update.

We are both using Windows 7 Enterprise (service Pack 1) , 64 bit operating system with 8.00 GB RAM

That is strange. I found some system requirements for ReadyApi as "Windows 7 SP1 with convenience rollup update (KB3125574) or a later Windows operating system (32- or 64-bit).".


Moreover, is that SoapUI project big? I often have problems with big projects - they open quite slowly. But never froze for me (I use windows 10 though)

If my answer helped please click on the 'Accept as Solution' button.
Champion Level 0

You can also check the ReadyAPI logs to see if it's throwing an error or any information that may be useful in troubleshooting. 


Click the Accept as Solution button if my answer has helped, and remember to give kudos where appropriate too!
Occasional Contributor

Thanks all - the issue boiled down to what Lucian mentioned - simply our Windows 7 machines were not running the SP1 windows6.1-kb3125574-v4-x64


thanks for your time

Why am I always right? Smiley Mad

If my answer helped please click on the 'Accept as Solution' button.
Showing results for 
Search instead for 
Did you mean: