Ask a Question

Ready API Error message in Header

SOLVED
angvarghese
Occasional Contributor

Ready API Error message in Header

Hi all,

 

I am trying to post a request in Readyapi (createmember) and getting the below error

<data contentType="null" contentLength="63"><![CDATA[ExternalUserId in AuthorizationHeader either invalid or missing]]></data>

The request is originally created in postman and imported into readyapi via project integration(postman collection). 

The reqeust which is failed in readyapi is perfectly working in postman. can anyone help me out here.

request

thanks

AV

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
angvarghese
Occasional Contributor

Re: Ready API throwing Error where the same reqeust works fine in postman

This is my readyapi request header 

angvarghese_0-1632315000681.png

 And below is my postman request header. well, there are hidden keys and values which i did not given in readyapi. Do you mean to give those hidden keys and values in readyapi header as well?

angvarghese_1-1632315170858.png

 

View solution in original post

angvarghese
Occasional Contributor

Re: Ready API throwing Error where the same reqeust works fine in postman

The issue has been solved 

Missing Authorization name instead of Token. 

angvarghese_0-1632316646962.png

 

it was given Token instead of Authorization and missing Bearer in front of actual token.

 

thanks 

 

View solution in original post

5 REPLIES 5
richie
Community Hero

Re: Ready API throwing Error where the same reqeust works fine in postman

Hey @angvarghese,

Considering the content of the error response you generated it appears there is a problem with the a parameter that builds the content of your authorization header.

What i do when i have different results in readyapi/soapui compared with postman is to execute the failing step in postman, go into postman's console and grab the full RAW requests details (so thats payload, full URL and Headers....the Headers are typically the issue when stuff works in postman but not readyapi/soapui) and keep them for later comparison.

Then execute the test step in readyapi/soapui again grabbing the full RAW details so i can then compare what is being published by postman compared with what is being published by readyapi/soapui. Thia approach typically indicates the differences (ignoring postmans stupid default headers) and the cause of the issue.

Try the above so you see what i mean, however id suggest you dont even need to do the above to resolve this. The issue is the userid parameter is your authentication/authorisation setup.

You just need to fix that

Ta

Rich
if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
ChrisAdams
Frequent Contributor

Re: Ready API throwing Error where the same reqeust works fine in postman

In Postman, look at the headers for the request.  Many headers are auto-generated (e.g. content length) so you can ignore those.  In fact, just above the headers list, there is a button that will hide those.

 

In the remaining list, there will be headers you'll need to created in SoapUI.  E.g. AuthorizationHeader

In SoapUI, you need to add the headers from Postman.

Below the payload element of the request, there are some tabs.  One of them is 'Header', click that and then add the headers you need.

angvarghese
Occasional Contributor

Re: Ready API throwing Error where the same reqeust works fine in postman

This is my readyapi request header 

angvarghese_0-1632315000681.png

 And below is my postman request header. well, there are hidden keys and values which i did not given in readyapi. Do you mean to give those hidden keys and values in readyapi header as well?

angvarghese_1-1632315170858.png

 

View solution in original post

angvarghese
Occasional Contributor

Re: Ready API throwing Error where the same reqeust works fine in postman

The issue has been solved 

Missing Authorization name instead of Token. 

angvarghese_0-1632316646962.png

 

it was given Token instead of Authorization and missing Bearer in front of actual token.

 

thanks 

 

View solution in original post

ChrisAdams
Frequent Contributor

Re: Ready API throwing Error where the same reqeust works fine in postman

Yep, that was what I and @richie meant.

cancel
Showing results for 
Search instead for 
Did you mean: