Ask a Question

Preferences cannot be saved after update to 3.5.0

SOLVED
dovy
Occasional Visitor

Preferences cannot be saved after update to 3.5.0

We have recently updated ReadyAPI from 3.3.0 to 3.5.0.

I have noticed that OK button in preferences doesn't work. And so, no setting in preferences can be adjusted.

Did anyone had the same issue? I am thinking maybe it could be related to 3.4.0 version added feature, but not sure how to fix it:

------------------------------------------

All ReadyAPI settings are now stored in the <User Folder>/.readyapi/readyapi-settings.xml file. Previously, these settings were stored in the <User Folder>/soapui-settings.xml file and were shared with SoapUI Open Source that was inconvenient if you used both applications.

If you have used ReadyAPI before, your settings will be copied to the new file at the first start of ReadyAPI 3.4.

Important notes:

  • Once you run ReadyAPI 3.4, it starts using a new settings file. Changes made in the new version will not apply to the older ones and vice versa.

  • If you specified the path to the default settings file in your automated test runs, you may need to update it.

11 REPLIES 11
TanyaYatskovska
SmartBear Alumni (Retired)

Hi @dovy,

Have you already reported this behavior to the Support Team? If you haven't, please submit a support ticket so that the R&D team could investigate what's happening:

https://support.smartbear.com/message/?prod=readyapi

 

---------
Tanya Yatskovskaya
SmartBear Community and Education Manager



I see no solution here. I have the same problem, cannot save changes to preferences. OK does nothing.

TanyaYatskovska
SmartBear Alumni (Retired)

Hi @Rclary,

 

Could you please try to do the following?

  • Close ReadyAPI
    go to the .readyapi folder in uses (C:\Users\%user%\.readyapi)
    Open the readyapi-settings.xml document using Notepad or Notepad++
    Find the following setting "setting id="Script Library"" and edit the path of the scripts to "C:\Program Files\SmartBear\ReadyAPI-3.5\bin\scripts"
    Save the file and restart ReadyAPI.

Does it help?

---------
Tanya Yatskovskaya
SmartBear Community and Education Manager



I have ReadyAPI 3.5.1 and I've been manually modifying readyapi-settings.xml (using notepad++), because although I have: C:\Program Files\SmartBear\ReadyAPI-3.5.1\bin\scripts saving still does not work. Another issue I have is that there is no "<con:setting id="SSLSettings@..." in readyapi-settings.xml so I can't set the SSL option "Use Windows Certificate Store" to true/false

The solution above does not work for me. 

JKolosova
SmartBear Alumni (Retired)

Hi all,

This is a known issue (RIA-15417), and it must be fixed in the next version of the tool (approx. 3.7.0). Sorry for the inconvenience.

 

As a workaround, you can delete the <User Folder>/.readyapi/readyapi-settings.xml and <User Folder>/soapui-settings.xml files, and relaunch the tool. On the next ReadyAPI start, the settings will be recreated and you will be able to update preferences in the UI.

 

Also, you can try to specify some integer values (greater than 0) for the "Max connections per host" and "Max total connections" options in the ReadyAPI HTTP settings (for example, 500 and 2000 respectively), and save the changes. After that, the settings dialog should start working correctly.


Julia

Customer Care Team

Did my reply answer your question? Please give Kudos or Accept it as a Solution to help others.
TSRAO
Occasional Contributor

I have the same problem, cannot save changes to preferences. OK does nothing.

From memory, the workaround supplied worked for me

TSRAO
Occasional Contributor

Can you please tell me that here, I have tried couple of options mentioned above. But nothing worked for me.

cancel
Showing results for 
Search instead for 
Did you mean: