Ask a Question

Not able to run an API with https url

New Contributor

Not able to run an API with https url

Hi Everybody, 


I'm trying to run an API which has the URL: (the host is set up in local network). The method is GET.


As this is https, it requires a token, which is: Access-Token and its value is: eyJhbGciOiJRwczotcGxlL.mFrs3Zo8eaSNcxiNfvRh9dqKP4F1cB


I'd tried in Postman (Chrome's extension) and it works fine. 



To automate more API, I'd tried once in SOAP UI NG (Ready API 1.7.0) but got the error:


2016-06-09 14:53:08 - Error getting response; Certificates does not conform to algorithm constraints




I'd been searching for the solution on the internet many days but unfortunately, all the threads are discussing about HTTP only.


I attach here 2 images, 1 is the result in Postman and 1 is the result in SOAP I NG. 


Please help me with the solution.

Thanks alot !



SoapUI does not understand encrypted SSL content.

Try to import the certificate to SoapUI keystore in preferences.

The certificates is located in "{soapui_home}/jre/lib/security" named cacerts

Thanks you for looking at my issue. 


I've done adding the certificate as below and tried re-running the test. The same issue happened. 

Is there something wrong , could you please help?



New Contributor

Still awaiting for more advices... please help 

Showing results for 
Search instead for 
Did you mean: