Ask a Question

Java exception when trying to load an Excel spreadsheet as data source


Java exception when trying to load an Excel spreadsheet as data source

ReadyAPI Java exception.JPG

The above error occurred when I attempted to import properties from an Excel spreadsheet.


Any ideas on how to fix that.?


Hi @hazel_chua,

I did not get the same error but I remember I needed to download Microsoft access database engine 2016 redistributable to make it work with TC. You can give it a go.

Community Hero

Use a text based properties, should be able get an example of property file online.
No need to use Excel for this case.


@nmrao Not my call to make what file I use, it's from a client and they are using Excel.  So, yes, I need to be able to connect to an Excel file that has multiple sheets in it.

@Reshail tried it, but it did not work. 😞

Update on this issue.  It seems like the formulae / VLOOKUP functions in the sheets are causing that Java issue.  Many of the cells in the workbook are referencing other sheets and cells across the workbook.  And that seems to cause the import / read of the Excel file to fail.


Tested with a dummy Excel file with 2 columns and 20 rows in only one sheet and that worked fine.  But, unfortunately again, that is not what my client's Excel file is like. Smiley Sad

Hmm.. never heard using an excel for keeping properties.
Are you sure that the file has key, value pairs?
You check with your team and let them know the supported format.


@nmrao not the project environment properties.  But the Excel spreadsheets do contain the data that is needed for the parameters of the tests to be run.  The keys are the column headers and the values are the rows which should be simple enough, even though many of the cells contain references/formulae that utilises cells from other spreadsheets in the same workbook.


The one of the sample projects used in the learning videos here used simple Excel files as well.  Just not the sort of complex, extensive ones that are found in the real world.

The statement, "import properties", in the original question confused me.


Hope "Evaluate formulas" check box is ticked.

Showing results for 
Search instead for 
Did you mean: