Ask a Question

How do I enable the Refactor button on the Refactoring REST Definitions Popup?

SOLVED
Hmartel
New Contributor

How do I enable the Refactor button on the Refactoring REST Definitions Popup?

Hi all,

 

I went through the process of refactoring my apis, but when I got to the end and had associated all of my existing apis with the new ones from the new schema - a Refactoring REST Definitions Popup appeared. I have gone through the popup a few times now, but can't seem to figure out how to get the Refactor button at the bottom of the popup to enable to complete the refactor. I click it and nothing happens.

 

Hmartel_0-1637156157389.png

 

Any thoughts?

 

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
sonya_m
Community Manager

Re: How do I enable the Refactor button on the Refactoring REST Definitions Popup?

Thank you for looking into this, Richie!

 

@Hmartel if the advice from the Community didn't help, please go ahead and open a ticket with support. The support engineers will be happy to help!


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

3 REPLIES 3
richie
Community Hero

Re: How do I enable the Refactor button on the Refactoring REST Definitions Popup?

Hey @Hmartel 

 

 

I haven't Refactored for a while (a number of versions ago) and it looks like the UI has changed since I did it. 

 

Can you confirm what version of ReadyAPI! you're using?

Can you confirm - I'm looking at your screenshot - so you're talking about the 'Refactor' button adjacent to the 'Cancel' button - right?

 

That sounds like a defect if it's not being enabled - unless perhaps it's context sensitive and you haven't made any changes (although you have said you made the changes and it still wasn't enabled).

 

If it's a defect, I suggest raising a Customer Support ticket as SmartBear will want to know if this is a defect (although it;s a bit of a big one for them to miss in their regression!)

 

I'm on the wrong laptop right now (no ReadyAPI! instance on my work Mac) - but I'll try and reproduce at home later on my personal windows.   I'm on 3.10.0

 

ta

 

rich

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Hmartel
New Contributor

Re: How do I enable the Refactor button on the Refactoring REST Definitions Popup?

Yes, the Refactor button next to the Cancel button on the Refactoring REST Definitions Popup. I'm using version 3.10.1 and as far as I can tell, I have done everything possible to get the Refactor button to enable.

sonya_m
Community Manager

Re: How do I enable the Refactor button on the Refactoring REST Definitions Popup?

Thank you for looking into this, Richie!

 

@Hmartel if the advice from the Community didn't help, please go ahead and open a ticket with support. The support engineers will be happy to help!


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

cancel
Showing results for 
Search instead for 
Did you mean: