Ask a Question

Handling environments : how to revert unwanted modifications

Regular Contributor

Handling environments : how to revert unwanted modifications


I'm working on a composite project and I use several environments. I previousely had many of them (depending on the target machine endpoint) and I removed them.

Recently I created a new environment for a single-shot test and then deleted it. However, when it comes to commit the modifications related to the tests done I have more than 2000 files that are modified. I realized that all of them have been set with the new environment id even though this one has been deleted.

Having a look to the settings.xml file at project level I realized that I have 21 environments set though I kept only 3 of them.

I can see that each single file has data for all the environments, even the deleted ones.


Is there a possibility to erase this unwanted data easily ?

why soap ui does not erase this when environments are deleted  ?


thanks for any help



Community Hero

What version of ReadyAPI are you using? Typically when dealing with composite projects, older versions of ReadyAPI did not delete certain files even if you removed them from the project, or it did not rename them if you renamed the artifacts in ReadyAPI. That being said, to get around this I will usually convert the project back to a single XML. I then delete the composite project folder, and then convert the single XML file back to a composite project to re-generate the directory and subdirectories/files.


Click the Accept as Solution button if my answer has helped, and remember to give kudos where appropriate too!
Regular Contributor

ah, it's a bit tricky ... I'll try that but right now I'm stuck in readyAPI 2.7 issues ... 😞


thank you



Hi Alex - I'm the Product Manager for ReadyAPI and I ALWAYS hate when I hear that someone is having trouble, especially with a new release!  Please reach out to me directly so we can help -


Regular Contributor

Actually I found out my problem, I tried to install an external plugin which was not compatible, removing it (I struggled a bit to find where it was) solved my problem



SmartBear Alumni (Retired)

@krogold, happy to hear that the issue has been resolved!

Happy testing 🙂

Tanya Yatskovskaya
SmartBear Community and Education Manager

Showing results for 
Search instead for 
Did you mean: