Ask a Question

Getting the warning message on report directory

New Contributor

Getting the warning message on report directory

While running the composite project from command line, I am getting the below warning message . Please can you advise how we can handle this. I am using ReadyAPI version 3.5.1


WARN [SoapUIJasperReportManager] The report directory is not specified. The default report directory will be used.

Community Hero

Hope the warning message is clear.

You can pass the respective argument by using the below link and specify the reports directory as needed by you if you don't like the tool to write them into default directory.

Looks -f option.


hi @nmrao ,


I had tried the -f option earlier as part of fetching of fetching the command line from test runner option. Had even tried changing it from default workspace to other directory; but it does not seem to find the required and still complains the same






Couple of points
- were you able to see the reports when it was showing warning?
- there is no relationship between workspace and executing the project command line.
- do you need to save reports into a customised directory only?
- were you able to change the reports directory from the tool? And are then reports generated?
- if so, you can use launch testrunner from ui and note down the command and use that directly next time in command line.

Showing results for 
Search instead for 
Did you mean: