Ask a Question

'Error getting response; Read TimedOut' in Ready API

New Contributor

'Error getting response; Read TimedOut' in Ready API

I have to POST from API and it takes time to execute though swagger (around 5-10 minutes) as scheduler runs

when I tried to execute with Ready API then I am getting error as 

'Error getting response; Read TimedOut'


I also tried to with Socket timeout as 0 but it is going infinite loop and POST API doesnt stop and unable to get data. Minimum 1 day record, I got in 5 minutes( this is minimum time taken to execute API through swagger)

SmartBear Alumni (Retired)

Hey there Anika,

I've tried setting Socket Timeout to 0 on my test case and it works as expected for requests over 1 minute. When you say it's entering an infinite loop, what do you mean by that? If Socket Timeout is set to 0 it will wait indefinitely for a response, but the response should come eventually. I'm assuming you've tried waiting the full 10 minutes?


SmartBear Alumni (Retired)

Thank you Russel!


@anika could you provide more details as Russel is asking? This will help us investigate the issue!

In case you solved it already - please share the solution with the Community as it may be of help to people going forward.


Alternatively, feel free to open a support ticket

Sonya Mihaljova
Community and Education Specialist

Showing results for 
Search instead for 
Did you mean: