Ask a Question

ERROR: com.eviware.soapui.impl.actions.UnsupportedDefinitionException

New Contributor

ERROR: com.eviware.soapui.impl.actions.UnsupportedDefinitionException

Hi - I am seeing such issues while creating a functional test case using swagger 2.0.

i see the Swagger is valid and i could check that by using my swagger hub as well.

 can you please let us me know if there is any way what could be parsing errors?

Community Hero

Hey @chaitu639,

I know you say swagger v2.0, but can you confirm the exact version number used to build the swagger? This does chsnge and can make a diff.

Also, can you please provide more details about exactly how and when the exception manifests?


if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

Hi Rich - Thankyou for checking on this.

API Spec was written based on Swagger 2.0 . I can see such behaviour when i am trying to create functional test case or creating a new project from the swagger definition.


i am also seeing issues when i try to convert from Swagger 2.0 to OAS 3.X using Swagger editor site. 


i am suspecting issues with tags that were used in swagger definition and not supporting in OAS

Showing results for 
Search instead for 
Did you mean: