Ask a Question

Cannot save anything in ReadyAPI?

Frequent Contributor

Cannot save anything in ReadyAPI?

Whenever I try to save my ReadyAPI project, I suddenly started getting this vague error -
Failed to Save Project, The filename, directory name or volume label syntax is incorrect. Here is a sample of the messages I see in ready-api.logs file. Why did this start happening suddenly and how to I prevent such issues from happening?

- ReadyAPI 3.0.0. Cannot upgrade it now.
- Windows 10 64bit.


[a timestamp] INFO [ClassicCompositeProjectHandler] Interface operation [a test step] not changed so not saved.
[a timestamp] INFO [ClassicCompositeProjectHandler] C:\some path\element.order is write-protected. It has not been saved.
[a timestamp] ERROR [ClassicCompositeProjectHandler] Can not write file [ write protected ] C:\some project\TeamCityService\BuildQueue.xml



Community Hero

Hey ,

Are there any special characters or spaces im the full path to the file?

Are there any special chars, especially illegal xml chars (e.g. chars that need escaping like the 5 xml entities) in any of the object names in your projects hierarchy?

Id double check and make sure there are none. It was quite a while ago but i had problem with paths in readyapi and once i removed dodgy chars/spaces my issue was resolved.


if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Frequent Contributor

I'll look into it. I wish ReadyAPI could give me better error messages so that I can figure out issues easily.

SmartBear Alumni (Retired)

Thank you for your advice Richie!


Hi @rajs2020! Did you manage to solve this?

Sonya Mihaljova
Community and Education Specialist

Frequent Contributor

I had to re download all project files and then load them into ReadyAPI. Things started working after that. So, I don't know why this problem occurred.

SmartBear Alumni (Retired)

Hi @rajs2020,

Great to hear that the issue disappeared!

Tanya Yatskovskaya
SmartBear Community and Education Manager

Showing results for 
Search instead for 
Did you mean: