Ask a Question

Cannot open some test suites


Cannot open some test suites


I am using ReadyApi 2.7.0 with a SoapUI Pro license. The following occurs in the SoapUI Pro tab.

I have several projects opened and each project contains several test suites. Usually, if I double click one project, it opens a tab listing all the test suites within this project and I can run the test suites from this tab. But for some reasons, this doesn't work anymore for some projects. When I double click on these projects, nothing happens. No error message. Just nothing. The same occurs if I select a particular test suite within this project. I can only open a test case.

On some others projects, it works as it used to (the test sute editor opens)

I believe this started after upgrading to 2.7.0 (not 100% sure of this statement). Any idea of what could cause this issue ?


Edit : the "Error log" tab doesn't show anything.

Super Contributor

When you say there are no error messages have you looked at the Error Log tab? Though on the face of it this does sound like a bug, I would log a support call with SmartBear:


Do post back here if you get any useful information.

Hi @Radford 


Thanks for your reply. Yes, I did not mention it but I did check this tab and it is empty. I'm going to add this info in my previous post

Hi @_Oliver_ ,


Let me know if you are getting this issue after cloning some assertions or some steps.

Because i usually i face this issue after cloning assertion from 1 Test Case to other Test Case.


And one more thing after clicking on Test Suite, check for the error under


Show Logs -> Ready API logs.


Click "Accept as Solution" if my answer has helped,
Remember to give "Kudos" 🙂 ↓↓↓↓↓

Thanks and Regards,
Himanshu Tayal

Hi @HimanshuTayal 


Thanks for your reply. I might have cloned some steps and/or assertions in those projects which have an issue but I am not sure of that.

There is nothing in the "ReadyApi Log" tab. I checked every log tab and no error message. No message at all actually.

Did you manage to fix this issue ?

@_Oliver_ ,


Yes i fixed this issue by:

1. Exporting the affected TestSuite at some location suppose Desktop and then deleting it from the ReadyAPI,

2. Then restart the ReadyAPI and again import that particular Test Suite from the Desktop.


It worked for me.


Click "Accept as Solution" if my answer has helped,
Remember to give "Kudos" 🙂 ↓↓↓↓↓

Thanks and Regards,
Himanshu Tayal

OK, thanks.

This is my first thread here, and I am curious about one thing. How come the previous post has been "accepted as a solution" ? I had no time yet to check if it solved my issue. 

Super Contributor

@_Oliver_  Sorry, I've no idea why the above why the above post was marked as the solution if you didn't do it? @TanyaYatskovska can you shed any light on this?

Hi, just opened a new account to report this here:


I have exactly the same problem. I have this problem after updating  the ReadyAPI suite from version 2.6 to 2.7.

This bug is very annoying, because it does not show the contents of the whole testsuite(s) anymore in the middle of the screen. Also execute all with the green RUN button is not possible anymore.

(no errors in the readyapi log)


In my opinion this is a serious bug. It puts me on a point to make the choice to downgrade to 2.6 again. I really dont want that.


Please provide with some correct solutions. (exporting en importing al testsuites is NOT really an option)

SmartBear Alumni (Retired)

Hi Guys,


I suppose that the issues may be specific to your projects. Thus, I suggest that you sent the project files before and after opening the project in the latest version to our Support Team. They will investigate the changes and come back with the solution. You can reach out to them here:

Tanya Yatskovskaya
SmartBear Community and Education Manager

Showing results for 
Search instead for 
Did you mean: