Ask a Question

Azure Devops result is different from ReadyAPI test result


Azure Devops result is different from ReadyAPI test result

while executing a job in azure devops for a test case , getting status code error 401 and job is getting failed , but when I am running the same test case in ReadyAPI directly its getting passed.


Community Hero

Hey @Jainsoumya

401 is authentication/authorisation. What sort of authentication/authorisation scheme is your api using and how are you passing the authentication/authorisation creds to your apis test steps?


if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

Hi @richie 


I am passing Auth via auth manager in readyapi steps and in devops I have followed this steps :

You can allow scripts and tasks to access System.AccessToken at the job level.

  1. Navigate to the job

  2. Under Additional options, check the Allow scripts to access the OAuth token box.

Then also I am getting the same issue , my scripts are getting failed via azure devops 

@joejoyce  Can you please help me with this 



Sorry, I cannot help here.  I have never used Azure DevOps.

No worries


@richie  Any luck with this ?

Hey @Jainsoumya. Can we confirm that Azure Devops has access to the instance of ReadyAPI that is running the test? I've seen this issue happen before in cases where there is an unexpected firewall between Azure and ReadyAPI. Are you able to ping the Azure Devops instance from the ReadyAPI machine, and vice versa?

Yes, I am able to access ReadyAPI instance from AzureDevops

Showing results for 
Search instead for 
Did you mean: