Showing results for 
Search instead for 
Did you mean: 

Playback - unable to locate button

New Contributor

Playback - unable to locate button

I've been able to record a script (single page app - webstore) but during checkout, the script is not able to identify a button used in the checkout flow (Click Event).  I've tried the various Object Identification options but still cannot successfully play back my script to completion.


Any suggestions woudl be greatly appreciated!


Community Manager

Re: Playback - unable to locate button

Hi @jocelynayson,

Could you please share a bit more information about the issue? Which parameters do you use in the checkpoint? Several images would clarify the situation.

Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
New Contributor

Re: Playback - unable to locate button

Sorry, I wasn't very descriptive.

The script I recorded steps through a checkout flow.

It's a single page application and the entire checkout flow takes place in a single page but in different sections.

I can get through entering the delivery information and selecting a shipping option, but at this point the script cannot locate the "Next" button and gets stuck, never completing checkout.


I've tried the various options for Object Identification but still unable to run the script to completion.



Re: Playback - unable to locate button

Hi there, 


We're sorry you're facing this issue. Can you please send the following info to to take a look -

  • If the app is publicly available or not?
  • The name of the project and test script


We'll check on our side and get back to you. 

We appreciate your patience and cooperation on this matter. 

New Here?
Join us and watch the welcome video: