Ask a Question

Unable to perform Smartbear- Add to review

SOLVED
prajakta1
New Contributor

Unable to perform Smartbear- Add to review

Hello,
On the Perforce client when I clicked on Smartbear- Add to Review I am
getting the below attached error. Tried a lot of ways to sort this out
but all in vain.
I request to please help me out to resolve this error.

 

 

//Error :

No SCM Configuration could be determined
!STACK 0
com.smartbear.scm.ScmConfigurationException: Could not parse version spec: Helix P4V/LINUX26X86_64/2019.1/1865170
at com.smartbear.scm.impl.newp4.P4System.getClientConfiguration(P4System.java:135)
at com.smartbear.scm.impl.newp4.P4System.getClientConfiguration(P4System.java:85)
at com.smartbear.scm.impl.perforce.PerforceSystem.getClientConfiguration(PerforceSystem.java:119)
at com.smartbear.scm.ScmUtils.requireScm(ScmUtils.java:597)
at com.smartbear.collaborator.ui.standalone.wizards.StandaloneScmConfigAddToReviewWizard$1.run(StandaloneScmConfigAddToReviewWizard.java:82)
at com.smartbear.collaborator.ui.wizards.ProgressWizardDialog$AsyncWorkerThread.run(ProgressWizardDialog.java:231)
Caused by: com.smartbear.cmdline.ScmCommunicationException: Could not parse version spec: Helix P4V/LINUX26X86_64/2019.1/1865170
at com.smartbear.scm.impl.newp4.PerforceExeVersionSpec.parse(PerforceExeVersionSpec.java:35)
at com.smartbear.scm.impl.newp4.cli.P4VersionCmd.result(P4VersionCmd.java:61)
at com.smartbear.scm.impl.newp4.cli.P4VersionCmd.result(P4VersionCmd.java:19)
at com.smartbear.scm.cmd.impl.ScmCmdRunner.run(ScmCmdRunner.java:28)
at com.smartbear.scm.impl.newp4.cli.P4CliConn.executeTextCmd(P4CliConn.java:165)
at com.smartbear.scm.impl.newp4.cli.P4CliConn.<init>(P4CliConn.java:82)
at com.smartbear.scm.impl.newp4.P4System.getClientConfiguration(P4System.java:120)

2 REPLIES 2
melgage
Staff

Prajakta1,

 

Please check the following to see if this resolves your PerForce issue:

 

This issue usually occurs in the system where the Perforce command-line client (p4) is not added to the environment path. Try to follow the steps below:

1. In the P4v client, select "Tools | Manage custom Tools | SmartBear - Add to Review" and click "Edit".
2. In the "Arguments" field, add the "--p4 your_current_path_to_p4" option after "--scm perforce".
Note: Don't change any other options.
3. Click "OK", restart the P4v client, and try to reproduce the issue.

 

If the issue still persists after following the steps above, ensure that the path to the "ccollabgui" file in the "Application" field of the "Edit Custom Tool" menu is correct, too. 

Mel Gage | Solutions Engineer - Collaborator, LoadNinja
e: Mel.Gage@SmartBear.com
sonya_m
SmartBear Alumni (Retired)

Thanks a ton, melgage!

 

@prajakta1 looks like you replied straight to the email notification, let me quote your reply here. Please make sure to reply inside the Community next time, thank you!

 

>>

Yes, thanks this was the issue and now it's solved. Thanks for your help.

<<


Sonya Mihaljova
Community and Education Specialist

cancel
Showing results for 
Search instead for 
Did you mean: