Ask a Question

Why is Performance Profiler indicating no routines analyzed

SOLVED
DavidJameson
Occasional Contributor

Why is Performance Profiler indicating no routines analyzed

This is almost embarrassing. I was an AQTime user 12 years ago and earlier using it with Delphi.

Now, I'm working on a project in C++ (just native) and, with a brand new license, I'm trying to use it to do a basic Performance Profile of my code. While I'm pretty sure I've followed all the instructions to make it work (https://support.smartbear.com/viewarticle/43100/) , after I do a brief run, where AQTime is clearly doing something since my application runs blatantly slowly, the summary tell me that 0 routines have been analyzed and 0 routines executed. So there's no call graph, call tree, etc.

 

The main executable shows up as a module, and "All Project Modules" (routines only) is checked in the "Code to Profile"

 

What have I forgotten to do?

 

Thanks in advance

11 REPLIES 11

Hi,

 

> One good idea might be [...]

I would say this is a good idea and I will vote for it if you create a feature request (https://community.smartbear.com/t5/AQtime-Feature-Requests/idb-p/AQtime_Feature_Requests) and reference this thread to provide Smartbear with more info to consider.

 

Regards,
  /Alex [Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
================================
cancel
Showing results for 
Search instead for 
Did you mean: