cancel
Showing results for 
Search instead for 
Did you mean: 

Loading of WSDL fails with wsse import and strcture.

punitronics
New Contributor

Loading of WSDL fails with wsse import and strcture.

Hi , 

 

We have the generatred interface file by name xxx.gsoap

we add manually wsse and the the structure corresponding to the security as below

#import "wsse.h"

struct SOAP_ENV__Header
{
mustUnderstand // must be understood by receiver
_wsse__Security *wsse__Security ; ///< TODO: Check element type (imported type)

};

and then the files are compiled with the project to generate the WSDL file.

the WSDL file seems to give the below exception when we try to load the WSDL in smart beer 5.3.0 SOAP UI.

( without adding import wsse and structure the generated WSDl works fine)

Error loading [http://www.w3.org/2001/10/xml-exc-c14n#]: java.lang.Exception: Failed to load url; http://www.w3.org/2001/10/xml-exc-c14n#, 0

and the problamatic lines in the WSDl files are below lines (difference between adding and before adding wsse)

<import namespace="http://www.w3.org/2001/10/xml-exc-c14n#" schemaLocation="http://www.w3.org/2001/10/xml-exc-c14n#"/>
<import namespace="http://www.w3.org/2000/09/xmldsig#" schemaLocation="http://www.w3.org/2000/09/xmldsig#"/>
<import namespace="urn:oasis:names:tc:SAML:1.0:assertion" schemaLocation="urn:oasis:names:tc:SAML:1.0:assertion"/>
<import namespace="urn:oasis:names:tc:SAML:2.0:assertion" schemaLocation="urn:oasis:names:tc:SAML:2.0:assertion"/>
<import namespace="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" schemaLocation="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd"/>
<import namespace="http://www.w3.org/2001/04/xmlenc#" schemaLocation="http://www.w3.org/2001/04/xmlenc#"/>
<import namespace="http://docs.oasis-open.org/ws-sx/ws-secureconversation/200512" schemaLocation="http://docs.oasis-open.org/ws-sx/ws-secureconversation/200512"/>
<import namespace="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd" schemaLocation="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd"/>

 

could you please let us know your expert advice in solving this issue.

 

Regards,

Puneeth J

1 REPLY 1
punitronics
New Contributor

Re: Loading of WSDL fails with wsse import and strcture.

Hi, 

 

I have an update that instead of schema location pointing to web address w3.org we have the local cached corresponding XSD files it works . 

 

Any pointers/better solution as we still need to edit manually the generated WSDL file to point to the manual local file location.

 

 

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors