Forum Discussion

UConnAnnMarie's avatar
3 years ago

TestExecute runs via RDP and errors because there are no test items in the project

I am running TestComplete 15.31.374.7 x64  and using TestExecute  15.31.374.11 x64 on a virtual machine.

I open my project and run a keyword test. 

I never see my application do anything and then it errors.

The log file shows that my project executed and has a green check mark.

it also shows an error that says 'The project failed to run'.  Extended information says The project cannot be run because there are no test items in it.

If I run my project on my desktop thru TestComplete, it works fine.

What am I doing wrong?





7 Replies

  • Marsha_R's avatar
    Champion Level 3

    Let's see the code you are using to launch TestExecute please

    • UConnAnnMarie's avatar

      I am running the script thru TestExecute which is on a server.

      According to what I've read online about using TestExecute, I'm supposed to right click on the TestExecute icon and then click Open.

      Then I'm supposed to right click the icon again and this time click on Open.  This gives me a list of all my keyword tests in the project.

      I have tried all the keyword tests.  I even opened my application that the script will use prior to running a keyword test so it doesn't have to do anything  but put text in a field and nothing happens.

      The screen doesn't change.

      Then it errors out.

      I can show you if you would like to Skype me.