Forum Discussion

Mehadi_Hasan's avatar
New Contributor
5 years ago

TestComplete Stuck on "Synchronization <internal>"

Recently I added 20 agents in network suites for distributed testing. I checked the individual machines to verify and run a test routine from the script successfully. But when I run the whole network suites for some of the agents an error message is logged on. The message is

Cannot run the remote project

 And those agents stopped and the other agents get stuck on "synchronizing <internal>".
"Cannot run the remote project" error is completely random for the agents. 
TestComplete version is: 14.20

TestExecute version is 14.10 for some agents and 14.0 for some others.

Can anyone please help to resolve this issue?


  • Mehadi_Hasan's avatar
    5 years ago

    Thank you, I guess, I figured out the issue. In the TestComplete I used a shared azure drive as a log location. I think the concurrent access of the same location from different agents caused the forced shutdown of the TextExecutes. And Thus raise synchronization error. 

6 Replies

  • AlexKaras's avatar
    Champion Level 3



    In addition to the above: it was always recommended to have exactly the same version of TestComplete and TestExecute on all interacting machines. Can you update TestExecute on all machines included in the suite and check if the problem persists?


  • TanyaYatskovska's avatar
    SmartBear Alumni (Retired)

    Hi Mehadi_Hasan,


    Let me quote the Running the Network Suite, Jobs and Tasks article:

    Documentation wrote:

    If your distributed test fails due to the “Cannot run the remote project” error, consider the following:

    • If your tasks execute projects or project suites, make sure that those projects or project suites are not empty and have at least one enabled test item. For more information on test items, see Test Items Page (Project Suite Editor) and Test Items Page (Project Editor).
    • If your tasks run script routines, make sure that those script routines do not contain any syntax errors. For more information on script syntax, see Checking Syntax.

    Please check this.



    • Mehadi_Hasan's avatar
      New Contributor

      Thank you for your reply.
      I already check the above-mentioned documentation but found no luck. Beside individual agents work fine when I run them from network suites individually. But when I run the whole network suites for some of the agents the above error logged. And this error was logged in random agents for each run. Is there anything I missed in setting or anywhere for parallel agents running. Coz the error mainly logged when network suites job starts the machine concurrently.