Forum Discussion

theabubakkar's avatar
theabubakkar
Occasional Contributor
4 years ago

TestComplete not getting Microsoft Chromium Edge (CEF Based Embed) as Browser object

Hi,

I am stuck while automating one of our Desktop application which has embedded chromium Edge.

 

TestComplete is not getting it as browser and page object. Sometime it get it as MSAA object and sometime it does not recognize the content and get it as a whole window like: .Window("Static", "", 1).Window("Chrome_WidgetWin_0", "", 1).Pane("Sign in to your account - Microsoft Edge").Document("Sign in to your account").

 

Please note that I have launched my application from within TestComplete with Command-line parameter: -injectCefHook.

 

Before our application was using google chrome chromium embeds and it was working fine. Recently our dev has started using Edge chromium embed and after that change it stopped picking the CEF objects.  

 

  • Hi,

     

    I would contact Support via the https://support.smartbear.com/testcomplete/message/ for to get an official confirmation that embedded Edge is supported and whether or not some specific settings are required.

    I would appreciate it if you update this thread with the reply from Support. (Whatever it will be)

     

3 Replies

  • AlexKaras's avatar
    AlexKaras
    Champion Level 3

    Hi,

     

    I would contact Support via the https://support.smartbear.com/testcomplete/message/ for to get an official confirmation that embedded Edge is supported and whether or not some specific settings are required.

    I would appreciate it if you update this thread with the reply from Support. (Whatever it will be)

     

    • theabubakkar's avatar
      theabubakkar
      Occasional Contributor

      Hi Alex,

       

      Thanks for the reply. Please guide me how I can update the thread with the reply from support ?

      • AlexKaras's avatar
        AlexKaras
        Champion Level 3

        Hi,

         

        how I can update the thread with the reply from support ?

        Just reply to any message within this thread and copy Support's answer.