Forum Discussion

forrestaustin's avatar
7 years ago

Program cant start because api-ms-win-crt-runtime-I1-1-0.dll is missing from your computer

I just downloaded the Testcomplete trial to determine if this product can be used to automate some of our GUI testing on windows desktop applications comprised of WPFs and Winforms. When I tried to make a simple test of opening the application, navigating to a certain page, and checking a box, I get thrown this error - "Program cant start because api-ms-win-crt-runtime-I1-1-0.dll is missing from your computer". The program has no problem opening on my computer without using Testcomplete so I'm not sure what the issue or fix is.

5 Replies

  • This error is quite common when you have installed a very new Windows OS. The issue occurs due to the missing of api-ms-win-crt-runtime-l1-1-0.dll file on your computer.


    You can fix the issue by:

    1. Updating Windows.
    2. Repairing Microsoft Visual C++ 2015 Redistributable.
    3. Manually installing Visual C++ Redistributable for Visual Studio 2015 from Microsoft.

    You can learn about each of the methods listed above here:




  • cunderw's avatar
    Community Hero

    How are you opening your program in test complete vs opening it normally?


    There is likely a difference somewhere, and we will need more information about how you're opening the application to troubleshoot. 

  • Normally to open the program, I just double click on the folder (on the desktop) that contains the program's executable, then I double click on the executable and it runs the program. On testcomplete I pressed record and did this same thing. Then I tried to replay the test I had just recorded and during that playback was when I got an error. (Also when I click run I need to quickly press windows_key+d in order to minimize the test complete window and allow it to find the desktop folder.) 

    • cunderw's avatar
      Community Hero

      So a few things, it sounds like this problem is more specifically related to your Windows or application configuration and not Test Complete itself:



      I'm not 100% sure why it would run just fine manually though. Perhaps it's not actually clicking the correct executable? Can you post any log screenshots you have and screen shots of the recorded test?


      I would also highly recommend going over the test complete documentation for tested apps as opposed to manually navigating and clicking on an executable:



      This would be a much better way of opening your application. 

      • forrestaustin's avatar

        Thank you for the help! That first link was able to fix to the problem. I think it should be noted though that this was an issue with Testcomplete trying to invoke a dll that was not already on my computer and should have been downloaded when I downloaded testcomplete. Anyways, the linked windows update was able to fix the problem. Thanks again!