Forum Discussion

jonnywaffles's avatar
New Contributor
6 years ago

Orders Tutorial Checkpoint



While trying to complete the Orders tutorial using the recorder, my test always fails during the Property Check point. Following the tutorial, the checkpoint checks row 5 for the changed text "Mark Twain". 


Property Checkpoint Aliases.Orders.MainForm.OrdersView, "wItem(5, 0)", cmpEqual, "Mark Twain", ... Checks whether the 'wItem(5, 0)' property of the Aliases.Orders.MainForm.OrdersView object equals 'Mark Twain'.


Unfortunately, the key test always fails with the following error message:


Unable to perform a property checkpoint, because the object "Aliases.Orders.MainForm.OrdersView" does not have a property named "(null)".


What gives? I am not checking for a property named null, and I can clearly see the test change the value before the Check point fails. I am very confused. Any help would be appreciated. 

6 Replies

  • tristaanogre's avatar
    Esteemed Contributor

    You're checking property wItem(5,0)?  Can we see the property checkpoint dialog screen for your checkpoint?  From what you're showing in your original post, it almost sounds like you have that entered as a string... that MIGHT be why you're getting the result you're getting.

  • Hi gang,


    Thank you for your help. The tutorial states:


    "In the Condition column, leave the default comparison condition, Equals (case-sensitive)."


    For whatever reason this always failed. I restarted TestComplete this morning, then I re-recorded the test again, and manually selected "Equals (case-sensitive)" it worked. It's the strangest thing. 


    I recorded again, and this time left the comparison default, without selecting anything manually, and it still works.


    I'm so confused. Maybe the reboot fixed it? How odd, whatever it works now!

    • Marsha_R's avatar
      Champion Level 3

      Yes, it's possible the reboot fixed it.  TestComplete is memory-hungry and weird things happen if there's not a lot available.  If you had too many other apps open at the same time, then you could have ended up in that situation, in which case the reboot cleared everything out and now TC is happy.


      If it happens again and you have no other apps running, you might document the issue and contact Support.  Some of us who have been on many versions of TC have run into a memory leak now and again.

  • After setting up the workspace which we had performed in the last tutorial, we have to create projects, test suites, test cases in order to test a given web service. Let us understand the steps involved in doing the same firstbankcard login.