Forum Discussion

whuang's avatar
Regular Contributor
3 years ago

Not able to call page object

Hi there,


I am getting "You are trying to call the "page" method or property of the following name mapping object: Name mapping item: browser" when I run this code


The name mapped item browser is any item that the ObjectType is Browser, this code was working perfectly before, but it started complaining just recently, what is more odd is this line of code only fail on a specific machine, I ran the exact same code on other machines, they all worked fine.


Does anyone have any idea what is wrong here?


Thanks in advance

3 Replies

  • AlexKaras's avatar
    Champion Level 3



    As the browser object is mapped to match any browser, likewise the page object, the most probable reason for this error is that some windowless browser process exists in your system. Quite often this happens with Internet Explorer.

    So I would close all browsers on the problematic machine and then check with Task Manager if any browser process remained in the memory.


    • sonya_m's avatar
      SmartBear Alumni (Retired)

      Thank you, Community!


      whuang does the suggestions help? If not, please provide more details.

  • Marsha_R's avatar
    Champion Level 3

    What is the difference between the machine where the test fails and the ones where it runs?


    Are the TestComplete versions different?

    Are the browser versions different?

    Are the app under test versions different?

    Do they differ in any other updates?