Forum Discussion

pbdarwin's avatar
pbdarwin
Occasional Contributor
4 years ago

Jira Versions supported by Test Complete

Hi All,

 

According to the SmartBear documentation below, they support up to Jira v7.12 or Jira Cloud. We are currently on Jira Server v8.11.1 and my support team declined my request to integrate Jira with Test complete saying that it is not supported.

 

Is the information mentioned in Test Complete system requirements wrong?

 

Is any body in the group integrated the latest versions of Jira (like 7.13, 8.1, 8.2, 8.3,8.4, 8.5, 8.6, 8.7, 8.8, 8.9, 8.10, 8.11, 8.12, 8.13, 8.14)

 

https://support.smartbear.com/testcomplete/docs/general-info/system-requirements.html

 

Regards,

PB

 

  • Hi pbdarwin 

    The Jira integration in TestComplete is implemented as a script extension that posts some requests to the Jira REST API. As you know, the "System Requirements" article says that we support Jira versions 5.0 to 7.12. This means that our QA team had tested the integration with these Jira versions and confirmed that there were no changes in their REST API - the integration worked successfully. So, using a later Jira version might cause issue only if Atlassian made any changes to the REST API in that version. In my experience though, TestComplete works with later Jira versions without any issues.

     

    So, I suggest that you try using it and let the Support Team know if you observe any issues.

2 Replies

  • TanyaYatskovska's avatar
    TanyaYatskovska
    SmartBear Alumni (Retired)

    Hi pbdarwin 

    The Jira integration in TestComplete is implemented as a script extension that posts some requests to the Jira REST API. As you know, the "System Requirements" article says that we support Jira versions 5.0 to 7.12. This means that our QA team had tested the integration with these Jira versions and confirmed that there were no changes in their REST API - the integration worked successfully. So, using a later Jira version might cause issue only if Atlassian made any changes to the REST API in that version. In my experience though, TestComplete works with later Jira versions without any issues.

     

    So, I suggest that you try using it and let the Support Team know if you observe any issues.