Forum Discussion

neelam's avatar
neelam
Occasional Contributor
8 months ago

How to handle the SSL certificate issue in test complete

Hi Team,

 

I am facing below issue : Whenever I run my URL , I get below error and not able to understand as how to handle below error. Test complete is not able to handle below error. Is there any way to handle below error?  After clicking on advanced only I can navigate to expected URL. Thanks in Advance

 

 

9 Replies

  • rraghvani's avatar
    rraghvani
    Champion Level 3

    See Possible Issues With Web Testing - "If Chrome cannot verify an SSL certificate provided by the tested web site, it shows the "Your connection is not private" error message page. Due to the specifics of implementation of this message in Chrome, TestComplete cannot interact with this page. It cannot access the internal objects of the message, so it will not record any actions you perform over it in Chrome."

    • neelam's avatar
      neelam
      Occasional Contributor

      Hi rraghvani ,

       

      Is there any solution to it? I will be referring Possible Issues of With Web Testing.

       

      Thanks,

      Neelam 

    • neelam's avatar
      neelam
      Occasional Contributor

      Hi rraghvani  

      I tried with chrome option under Possible Issues with web Testing but i am not able to find below  option on my machine : 

      There is not option of ThirdPartyBlockingEnabled.

       

      It would be great if you can help me out?

       

      Thanks,

      Neelam Rajput

    • neelam's avatar
      neelam
      Occasional Contributor

      Hi DWalsh 

       

      As Intelligent Quality is quite vast. Could you please explain me in detail as how to install this and how it will work? Yes I am using paid version.

       

      Thanks,

      Neelam

    • neelam's avatar
      neelam
      Occasional Contributor

      Hi rraghvani ,

      Is there any solution which I can handle via code?

       

      Thanks,

      Neelam

    • neelam's avatar
      neelam
      Occasional Contributor

      Hi rraghvani  

       

       I have tried below solutions as per link shared by you: 

      For the issue of bypassing the "connection is not private" page, you can try one of the following:

      1. Click a blank section of the denial page.
      2. Using your keyboard, type "thisisunsafe". This will add the website to a safe list, where you should not be prompted again

      OR 

      This option will only work for requests to localhost over HTTP.

      1. In the Chrome address bar, type “chrome://flags/#allow-insecure-localhost
      2. Select the “Enable” link.

       

      The first option works temporary , if I clear cache , it starts showing up again

      The second option does not work for me , I enabled the below option  : 

      but noting happened.

       

      Thanks,

      Neelam

  • rraghvani's avatar
    rraghvani
    Champion Level 3

    It's not possible to handle via code.

     

    If do an internet search, there's plenty of examples of disabling SSL. By disabling SSL, it's considered to be a security issue!